Can't start my Subie! brotherhood help!
Results 1 to 10 of 10

This is a discussion on Can't start my Subie! brotherhood help! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So far I never had problems with it, but today after work it wouldn't start, I jumped it then it ...

  1. #1
    Registered User Subbyrex05's Avatar
    Join Date
    Mar 2005
    Location
    Appleton,WI
    Posts
    48

    Unhappy Can't start my Subie! brotherhood help!

    So far I never had problems with it, but today after work it wouldn't start, I jumped it then it did start, after I got home I shut it off and it wouldn' start again... dash lights turn on, all lights turned on... It made click noises as I was trying to start it up, but no luck then I charged the battery for about 10 min then I tried to start it and no luck again and it didn't drained the battery at all, should I replace the alternator or the starter OR what should I look for!? any feedback will be appreciated!!
    Bought a house!!! Can't afford mods right now!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Would Never, Ever Say Something Bad About an Admin's Mom SonicWagon's Avatar
    Join Date
    Jul 2007
    Location
    Santa Cruz New Mexico
    Posts
    5,741
    the battery is working fine?

    can you try to jump it of another car? if that works it just needs a new battery most likely
    "It is at our most challenging times that we must cheat our very hardest" - Eric Theodore Cartman
    Quote Originally Posted by Weasel 555 View Post
    so whose up for been banned?
    Quote Originally Posted by RayfieldsWRX View Post
    I is teh b1ggest douche evarrrr!~

  4. #3
    Geriatric Ginger Mod Rogan's Avatar
    Join Date
    May 2007
    Location
    behind the wheel
    Posts
    8,188
    I Support ClubWRX
    I'm calling battery. May have a dead cell.

    If you jump start it, and it starts fine, runs ok, but wont start on it's own = BATTERY.

    If you can drive it once it starts, it's not the starter or alternator. It's the battery.
    Rogan o_0
    '96 Dodge 2500 CTD @ 40psi - over 700 lb/ft TQ, 7" stack, and 5speed! - SOLD
    '01 Dodge 2500 CTD 6-holed hand-shaker - 3850# dual disk - 900 lb/ft - SOLD
    '97 Dodge 3500 CTD DUALLY built Auto - 40psi boosties - 750 lb/ft

  5. #4
    Registered User Subbyrex05's Avatar
    Join Date
    Mar 2005
    Location
    Appleton,WI
    Posts
    48

    will do!

    As soon as Autozone opens up their doors I'll be in to get a battery good thing it still has warranty on it... thanx homies!!
    Bought a house!!! Can't afford mods right now!!!

  6. #5
    Registered User Timdog1650's Avatar
    Join Date
    Aug 2002
    Location
    Virginia Beach, VA
    Posts
    6,170
    Quote Originally Posted by Subbyrex05 View Post
    As soon as Autozone opens up their doors I'll be in to get a battery good thing it still has warranty on it... thanx homies!!
    They can do a test of your battery to see if it's shot. If the battery has a warranty just get a new one, but if it's going to involve money out of pocket, get them to test it first, just to make sure.

  7. #6
    Banned
    Join Date
    Oct 2007
    Location
    Cali
    Posts
    14
    Sorry to say this rogan just because the car will run does not mean the alternator is fine. the alternator could be putting out only 12 volts which is all the car needs to run but that 12 volts wont charge the battery it needs to be putting out at least 13.6-14.2 volts in order correctly maintain a full state of charge. With that said subyrex05 if you will be driving the rexi to auto zone have them check your alternator with a little computer that plugs on to the cables and checks the voltage and the cells of the battery. if not get a volt meter from radioshack fairly inexpensive and check the voltage at the battery posts with the engine running. If it is not in between 13.6-14.2 volts when idling you really need to replace your alternator or this problem with happen again with the new battery. good luck. I hate hearing of another subie down. we all need to unite

  8. #7
    Registered User Subbyrex05's Avatar
    Join Date
    Mar 2005
    Location
    Appleton,WI
    Posts
    48

    Thank You All!!

    IT'S ALIVE!!!!!!! I went to Autozone and they tested the battery and found out it was junk they also ran a test on the alternator and it was fine, so I got my battery replaced it had warranty so it didn't cost me a penny, but it did cause pain in my heart seen my subie die on me for the first time ever , once again thank you all for your help!!
    Bought a house!!! Can't afford mods right now!!!

  9. #8
    Would Never, Ever Say Something Bad About an Admin's Mom SonicWagon's Avatar
    Join Date
    Jul 2007
    Location
    Santa Cruz New Mexico
    Posts
    5,741
    your subaru did not die, the battery did.
    "It is at our most challenging times that we must cheat our very hardest" - Eric Theodore Cartman
    Quote Originally Posted by Weasel 555 View Post
    so whose up for been banned?
    Quote Originally Posted by RayfieldsWRX View Post
    I is teh b1ggest douche evarrrr!~

  10. #9
    Registered User Subbyrex05's Avatar
    Join Date
    Mar 2005
    Location
    Appleton,WI
    Posts
    48
    fine it didn't it passed out!
    Bought a house!!! Can't afford mods right now!!!

  11. #10
    Geriatric Ginger Mod Rogan's Avatar
    Join Date
    May 2007
    Location
    behind the wheel
    Posts
    8,188
    I Support ClubWRX
    glad you're back in business
    Rogan o_0
    '96 Dodge 2500 CTD @ 40psi - over 700 lb/ft TQ, 7" stack, and 5speed! - SOLD
    '01 Dodge 2500 CTD 6-holed hand-shaker - 3850# dual disk - 900 lb/ft - SOLD
    '97 Dodge 3500 CTD DUALLY built Auto - 40psi boosties - 750 lb/ft

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •