Confirmed, Im buring oil
+ Reply to Thread
Results 1 to 2 of 2

This is a discussion on Confirmed, Im buring oil within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I started getting a smell in my STI last friday and wasnt sure what it was. I made a post ...

  1. #1
    Registered User ooWRXoo's Avatar
    Join Date
    Jul 2007
    Location
    Montreal
    Posts
    147

    Confirmed, Im buring oil

    I started getting a smell in my STI last friday and wasnt sure what it was. I made a post here asking people for some help. And was told that i am either burning oil or my clutch since i wasnt 100% sure of what i was smelling.

    So this time, on Sunday, when i started gettting the smell again, i pulled over, popped the hood and stuck my nose all over to find the origin of the smell. Since i saw small amounts of smoke this time, im sure im burning oil and not the clutch.

    the smoke was coming for the leftside (turbo-side) behind the engine (betwen firewall and motor). right around the turbo.

    any ideas as to where i could be leaking?
    valve cover gasgett? hopefully not the head gasgett on that side?

    any comments or instructions would be very appreciated.
    Black 2004 WRX STi - BlobEye Syndicate #200
    "As I walk through the valley of the shadow of death, I shall fear no EVO."
    I'm always looking for Subaru fanatics in the greater Montreal area. If your close, send me a pm.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    There's a lot of things in that area that could be leaking. Sorry, but you're going to have to track it down yourself!
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •