Urgent Please Help!!! Engine Misfire Not Sure Why??
Results 1 to 8 of 8

This is a discussion on Urgent Please Help!!! Engine Misfire Not Sure Why?? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am not sure why, however my engine has recentyl started to misfire, if i start it up, it iddles ...

  1. #1
    Registered User
    Join Date
    Jan 2008
    Posts
    41

    Red face Urgent Please Help!!! Engine Misfire Not Sure Why??

    I am not sure why, however my engine has recentyl started to misfire, if i start it up, it iddles eratically and goes below 1000rpm and im not sure why this is???
    it seems hard to get it to rev above 3rpm as it is misfiring alot, drove it earlier and it was strugling to move expecially when moving off in 1st gear.

    Any 1 got ne ideas what this could be??

    Its is a 1993 wrx 2.0 turbo

    Thanks in advance

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User justin.jordan2's Avatar
    Join Date
    Feb 2008
    Location
    FAIRFIELD, CALIFORNIA
    Posts
    937
    Quote Originally Posted by az_e11 View Post
    I am not sure why, however my engine has recentyl started to misfire, if i start it up, it iddles eratically and goes below 1000rpm and im not sure why this is???
    it seems hard to get it to rev above 3rpm as it is misfiring alot, drove it earlier and it was strugling to move expecially when moving off in 1st gear.

    Any 1 got ne ideas what this could be??

    Its is a 1993 wrx 2.0 turbo

    Thanks in advance
    def check ur plugs, make sure ur timeing belt isnt loose....
    COBB FLASHED STAGE 2, UPPIPE, DOWNPIPE WITH HIGH FLOW CAT, AND FULL 3 INCH CAT BACK, 160 CRUCIAL RACING THERMOSTAT, K&N FILTER. TRACK: 1/4 MILE 13.66 102.7 MPH ON THE COBB OTS MAP

  4. #3
    Registered User WRX206's Avatar
    Join Date
    Feb 2008
    Location
    Kent, Wa.
    Posts
    43

    Unhappy This may scare you...

    after my check engine light came on, I had an OBD code scan, it read engine misfire in cyl. 1, so I figured it was the plugs, when I went to change them I found that one of them was broken(the plug was being held together by the boot) after replacing them she ran fine for about 3 days before she started acting up, a few days later she was burning oil badly and soon after smoking out the ass. The mechanics at P.I.A. said it was most likely caused by a turbo failure of some sort, check youre psi, make sure youre wastegate is working properly, I hope It turns out to be less, just preparing you for the worst. goodluck.
    Last edited by WRX206; 04-14-2008 at 12:38 AM. Reason: it turned out to be a blown piston.

  5. #4
    Registered User
    Join Date
    Jan 2008
    Posts
    41

    Red face Re - Misfire

    ok i just went outside now to go listen to the misfire again, but now the car doesnt want to start up, well on turn of the key the engine does fire up for a split second but then it imedietly stalls, cant get it to stay on.
    Im starting to think it cud be a fuel problem, because on my way back it felt like i was runnin low on fuel but i checked and ive got loads in there.
    I just notcied aswell when u first go to start the car on ignition position 2 you usuali hear a nosie from i think the fuel tank like something enganging a relay or something you know what i mean? but now I noticed this noise soundz really different than usual not as smooth more of a humming sound.

    any ideas any 1??

    ***and sorry to hear bout ur car, just hope i dnt have that problem

  6. #5
    Registered User justin.jordan2's Avatar
    Join Date
    Feb 2008
    Location
    FAIRFIELD, CALIFORNIA
    Posts
    937
    Quote Originally Posted by az_e11 View Post
    ok i just went outside now to go listen to the misfire again, but now the car doesnt want to start up, well on turn of the key the engine does fire up for a split second but then it imedietly stalls, cant get it to stay on.
    Im starting to think it cud be a fuel problem, because on my way back it felt like i was runnin low on fuel but i checked and ive got loads in there.
    I just notcied aswell when u first go to start the car on ignition position 2 you usuali hear a nosie from i think the fuel tank like something enganging a relay or something you know what i mean? but now I noticed this noise soundz really different than usual not as smooth more of a humming sound.

    any ideas any 1??

    ***and sorry to hear bout ur car, just hope i dnt have that problem
    clogged fuel filter on pump. bad pump, still make sure ur timing belt, isnt loose, and make sure ur getting spark, just take out sparck plug, hold it agaist block and have someone turn over engine see if you can see spark, then you will know if its a fuel or spark, prob.
    COBB FLASHED STAGE 2, UPPIPE, DOWNPIPE WITH HIGH FLOW CAT, AND FULL 3 INCH CAT BACK, 160 CRUCIAL RACING THERMOSTAT, K&N FILTER. TRACK: 1/4 MILE 13.66 102.7 MPH ON THE COBB OTS MAP

  7. #6
    Registered User WRX206's Avatar
    Join Date
    Feb 2008
    Location
    Kent, Wa.
    Posts
    43

    Arrow Test UR F.P.

    There are many ways to test your fuelpump, it depends on you greasemonkey abilities or on how much money you want to spend. If you can remove the pump yourself I'd just replace it. If you plan on modding look into a Walbro 255lph($125 on Ebay) it'll prepare you for larger injectors but you'll end up having some tuning or purchasing a cobb access port. goodluck.

  8. #7
    Registered User justin.jordan2's Avatar
    Join Date
    Feb 2008
    Location
    FAIRFIELD, CALIFORNIA
    Posts
    937
    Quote Originally Posted by WRX206 View Post
    There are many ways to test your fuelpump, it depends on you greasemonkey abilities or on how much money you want to spend. If you can remove the pump yourself I'd just replace it. If you plan on modding look into a Walbro 255lph($125 on Ebay) it'll prepare you for larger injectors but you'll end up having some tuning or purchasing a cobb access port. goodluck.
    +1 try this website for the 255 WB 100.00 for the whole kit....hopupracing.com they have everything you need or it will at least give you an idea wat to search for.
    COBB FLASHED STAGE 2, UPPIPE, DOWNPIPE WITH HIGH FLOW CAT, AND FULL 3 INCH CAT BACK, 160 CRUCIAL RACING THERMOSTAT, K&N FILTER. TRACK: 1/4 MILE 13.66 102.7 MPH ON THE COBB OTS MAP

  9. #8
    Registered User
    Join Date
    Jan 2008
    Posts
    41

    Red face Re-Misfire

    went out and had a final check and now it doesnt start at all just turns over, im guessing it must be a fuel problem as it now seems the fuel that was there has completly gone as it is not firing at all now.
    Hopefulli get the fuel pump checked.

    Thanks for all your help guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •