help
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So i went to clean my MAF yesterday and noticed that the jacka** that owned the car before me stripped ...

  1. #1
    Registered User adizzle02's Avatar
    Join Date
    Mar 2008
    Location
    Sandy Utah
    Posts
    963

    help

    So i went to clean my MAF yesterday and noticed that the jacka** that owned the car before me stripped the ever loving hell out of one of the screws that holds it on. There is just a big round hole on the screw head. Anyone have any suggestions for getting this screw out? i was thinking maybe superglueing the screwdriver onto the screw but im not so sure that will work.
    VF39'd and Clark Tuned
    BugEyeMafia #176
    Basshead Member #3

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User jeffmm06's Avatar
    Join Date
    Sep 2007
    Location
    Sacramento, CA
    Posts
    2,138
    You might try using an ever so small drill bit, im not sure if theres one small enough to drill into it with out ruining the ID threads.
    2005 WRB WRX "was" STAGE 2

  4. #3
    Registered User adizzle02's Avatar
    Join Date
    Mar 2008
    Location
    Sandy Utah
    Posts
    963
    i was thinking about that too but im afraid of damaging the threads like you mentioned. The previous owner must have used a gorrila to put the screws back in they were tight
    VF39'd and Clark Tuned
    BugEyeMafia #176
    Basshead Member #3

  5. #4
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0

  6. #5
    Registered User jeffmm06's Avatar
    Join Date
    Sep 2007
    Location
    Sacramento, CA
    Posts
    2,138
    Do you have the factory intake? The threads are in the maf hose and not the sensor correct? I cannot remember my car is at home in the garage.
    2005 WRB WRX "was" STAGE 2

  7. #6
    Registered User adizzle02's Avatar
    Join Date
    Mar 2008
    Location
    Sandy Utah
    Posts
    963
    yeah i've got the stock intake. I cant remember it the threads are on the sensor or not ill have to double check
    VF39'd and Clark Tuned
    BugEyeMafia #176
    Basshead Member #3

  8. #7
    Registered User jeffmm06's Avatar
    Join Date
    Sep 2007
    Location
    Sacramento, CA
    Posts
    2,138
    If the threads are in the hose, and not the sensor housing, and if you want to get a cobb intake, as the threads are on the intake. You could just drill through and not worry about anything, just dont mess up the sensor, this would be your last resort if you cant get anything to work.
    2005 WRB WRX "was" STAGE 2

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •