Flickering Headlights
Page 1 of 2 12 LastLast
Results 1 to 15 of 19

This is a discussion on Flickering Headlights within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Got an 04 WRX, still kinda new to me, just out the shop with a tranny rebuild, and new clutch. ...

  1. #1
    Registered User
    Join Date
    May 2007
    Location
    Delaware
    Posts
    174

    Flickering Headlights

    Got an 04 WRX, still kinda new to me, just out the shop with a tranny rebuild, and new clutch. For some reason, from time to time, at night with my headlights on, when i signal, then make the turn, or me turning them off manually sometimes my headlight with go out/or highbeam for a quick second, then flicker back. any ideas..please help..

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Hubiethesubie's Avatar
    Join Date
    Mar 2008
    Location
    Wenatchee, WA
    Posts
    85
    My 04 2.5rs does the same thing. I'm going to take it down and have the dealership fix it. Hopefully under warranty.

  4. #3
    Registered User
    Join Date
    May 2007
    Location
    Delaware
    Posts
    174
    Please let me know what the culprit is. I need to get this thing fixed too. I have no warranty on my car.

  5. #4
    Registered User Hubiethesubie's Avatar
    Join Date
    Mar 2008
    Location
    Wenatchee, WA
    Posts
    85
    Will do.

  6. #5
    Registered User adizzle02's Avatar
    Join Date
    Mar 2008
    Location
    Sandy Utah
    Posts
    963
    almost sounds like a bad ground somewhere
    VF39'd and Clark Tuned
    BugEyeMafia #176
    Basshead Member #3

  7. #6
    Registered User
    Join Date
    May 2007
    Location
    Delaware
    Posts
    174
    Thank you. I have a feeling it was something the dealer did, because it wasn't like that before, and the def, disconnected my battery, The service guy is like your car must have had some issues. They already screwed my front bumper, so now its back in the shop. All my presets were gone from the radio. Other than the battery, where else is there a ground?

  8. #7
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    5,994
    I Support ClubWRX
    Quote Originally Posted by adizzle02 View Post
    almost sounds like a bad ground somewhere
    +1 Cleaning the baterry terminals and grounding points can do wonders.A ground kit can help too if you are running alot of stereo equipment.Upgrading to a better battery like an Optima or something might help too.Check both points of contact for the battery terminals (battery-block/tranny).
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  9. #8
    Registered User
    Join Date
    May 2007
    Location
    Delaware
    Posts
    174
    Will do. Car is currently in the shop, till next week. thanks again. didnt realize there was a ground on the tranny as well..explains my problem.

  10. #9
    Registered User
    Join Date
    Mar 2008
    Posts
    25
    yea my 04 wrx does the same thing too but not very often though

  11. #10
    Registered User snowflowmfg's Avatar
    Join Date
    Nov 2007
    Location
    Sonora, CA
    Posts
    1,645
    there was a bugeye wagon at a rallyX race that had it's lights going on and off. Looked relatively stock on the outside besides wheels, but was probably stage 2 or soemthing.
    Hawk-Eye Alliance #116
    Dirty Crew #27

  12. #11
    Registered User etshulda's Avatar
    Join Date
    Oct 2007
    Location
    NH USA
    Posts
    609
    Yes my 04 WRX did the same thing. I bought the car new so It sounds like this is one of those common issues. The STI I've got now does not have this problem.
    The fast and the "Yeah right!"
    Blobeye #60
    2004 WRX STi Java Black Swirl
    2004 WRX san remo wingless sold
    99 Impreza 'L' grocery getter sold

  13. #12
    Registered User
    Join Date
    May 2007
    Location
    Delaware
    Posts
    174
    Any luck Hubie? my car is still in the shop..

  14. #13
    Registered User Hubiethesubie's Avatar
    Join Date
    Mar 2008
    Location
    Wenatchee, WA
    Posts
    85
    The dealership said they can't get me in until sometime after the 10th of this month, something to do with people getting their studded tires off.
    The freaky thing is it's stopped doing it lately. Took it down to H & D Auto who specialize in Subarus period, wouldn't do it for the life of me, pbbbb Murphy's Law, eh? But, now the audible beep when you lock and unlock your car is fruiting out. Wont do it in front of a mechanic though
    ~My wife says I drive like a "grandpa", but she drives like a "bat out of hell"
    03 Wrx
    04 2.5RS

  15. #14
    Registered User
    Join Date
    May 2007
    Location
    Delaware
    Posts
    174
    thats funny, sometimes mine does that as well. some times beep, sometimes no beep. keep me posted.

  16. #15
    Registered User LRPct's Avatar
    Join Date
    Jan 2006
    Location
    Lime Rock Park Ct...
    Posts
    264
    my lights went and acted all wacky on me for awhile too. It turns out it was my trailer lights wiring harness causing the issues.. Don't know if you guys have a hitch and lights...

    I had read somewhere before that sometimes the flasher switch would cause problems like that. I replaced mine from auto zone for like 8$ and 2 minutes. That was before i discovered my real issue though. The switch didn't help me at all in that case.. good luck...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •