big boom on freeway
Results 1 to 10 of 10

This is a discussion on big boom on freeway within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; my friend installed a vf39 turbo, sti pink injectors, and walbro fuel pump over the weekend. he had some trouble ...

  1. #1
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473

    big boom on freeway

    my friend installed a vf39 turbo, sti pink injectors, and walbro fuel pump over the weekend. he had some trouble getting the IC back onto the TB cause the stock hose wasn't long enough. he bought a new one at kragen and tighted it as much as possible cause it was a bit too big still.

    well after the whole install, he went to test out his car on the freeway. the first time he floors it, a loud boom can be heard and the car just stalls out. he found out that the stock IC has popped off and now he can't rev past 2500rpm.

    anybody know if he is in limp mode and how this can be fixed? any help would be great!
    Last edited by SuBiEklD; 03-17-2008 at 04:49 PM.
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Did you put the IC back on?

  4. #3
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473
    yeah he put the stock IC back on and reseted the ECU with the AP. he still can't rev past 2.5k rpm. he said the CEL went away after reinstalling the stock IC.
    Last edited by SuBiEklD; 03-17-2008 at 04:49 PM.
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

  5. #4
    Registered User teflon_jones's Avatar
    Join Date
    Apr 2007
    Location
    8000' up in Colorado
    Posts
    6,753
    What happens when it gets to 2500 rpm? Does it sound normal below that rpm? Does the car start and idle normally?
    Scott
    Past Subies - '11 STI Limited stage 1+ and '04 STi stage 2+
    '13 Wrangler Rubicon - custom front bumper w/12k lb winch & off-road lights, skid plates, diff guards, etc.
    '04 Porsche 911 Turbo GT2 clone 600 HP/TQ
    '77 F-150 heavily modded for off-roading

  6. #5
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473
    Quote Originally Posted by teflon_jones View Post
    What happens when it gets to 2500 rpm? Does it sound normal below that rpm? Does the car start and idle normally?
    the car won't allow him to rev past 2.5k about. it's like the car has a "stuffy nose" in a way like it wants more power but it won't go. the idle starts out rough but subsides and becomes normal.
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

  7. #6
    Registered User 07wrxguy's Avatar
    Join Date
    Dec 2007
    Posts
    104
    i had the same problem when i put my downpipe on. i didnt install the ic right and it was leaking the car wouldnt move after 3,ooo rpm. do he have the sti tmic or any other aftermarket ic. it could be leaking from somewhere. thats all i got

  8. #7
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473
    Quote Originally Posted by 07wrxguy View Post
    i had the same problem when i put my downpipe on. i didnt install the ic right and it was leaking the car wouldnt move after 3,ooo rpm. do he have the sti tmic or any other aftermarket ic. it could be leaking from somewhere. thats all i got
    no. he has the stock 03 wrx TMIC right now. he just ordered a larger TMIC.

    after installation and everything, it was late and he didn't really get the chance to most of the lines. he'll probably check tonight.

    thanks for all the responses so far! more help/tips/info pl0x!
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

  9. #8
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473

    quick update

    my friend went and checked the connections around the turbo. he found a small opening between the turbo inlet and the turbo (not flush). my guess is that this is throwing off the MAF and causing his limp mode? correct if i may be wrong.
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

  10. #9
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    did he zip tie all of the boost lines ?
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  11. #10
    Registered User SuBiEklD's Avatar
    Join Date
    Aug 2006
    Location
    Strict Emissions Law, California
    Posts
    473
    Quote Originally Posted by rr1911 View Post
    did he zip tie all of the boost lines ?
    i don't think so.
    BLOBEYE SYNDICATE #524
    "Life isn't about the number of breaths we take, but the moments that take our breath away"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •