97 Subaru WRX STI ver 4 idle problems
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 97 Subaru WRX STI ver 4 idle problems within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi All I'm happy to be part of your forum. I have a problem with my suby and was wondering ...

  1. #1
    Registered User
    Join Date
    Mar 2008
    Posts
    2

    97 Subaru WRX STI ver 4 idle problems

    Hi All



    I'm happy to be part of your forum.

    I have a problem with my suby and was wondering if youd be able to help me with it.

    Its the idling at stand still. Its ok when its cold it idles at 1000rpm roughly with is great but when its been running for awhile ill pull up to lights and the rev's drop so low it cuts the motor out. quite embassarsing lol. if it dosent cut out it drops to 100rpm or so then raises to about 800rpm is this right???



    Thanks,

    Brad Simmo

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator timber's Avatar
    Join Date
    Apr 2005
    Location
    St. George, Ut.
    Posts
    3,718
    I Support ClubWRX
    Quote Originally Posted by bradsimmo View Post
    Hi All



    I'm happy to be part of your forum.

    I have a problem with my suby and was wondering if youd be able to help me with it.

    Its the idling at stand still. Its ok when its cold it idles at 1000rpm roughly with is great but when its been running for awhile ill pull up to lights and the rev's drop so low it cuts the motor out. quite embassarsing lol. if it dosent cut out it drops to 100rpm or so then raises to about 800rpm is this right???



    Thanks,

    Brad Simmo
    I'm not sure if it's relative to your vehicle, but I was having a similar problem with my '02. Turned out to be the throttle position sensor.
    "Never Launched"
    Dougie
    - Founder, 250,000 mile club
    -5,000 posts

  4. #3
    Registered User
    Join Date
    Mar 2008
    Posts
    2

    throttle position sensor?

    hi where is this usally located?

  5. #4
    Moderator timber's Avatar
    Join Date
    Apr 2005
    Location
    St. George, Ut.
    Posts
    3,718
    I Support ClubWRX


    You can't really see it in this pic, but it is attached to the side of the throttle body ( background of white circle) the red circle shows the harness attachment.
    "Never Launched"
    Dougie
    - Founder, 250,000 mile club
    -5,000 posts

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •