Major Problem
Results 1 to 12 of 12

This is a discussion on Major Problem within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hello guys im new to this club and im from The Bahamas. So im jus sayin hello. But I also ...

  1. #1
    Registered User
    Join Date
    Mar 2008
    Location
    Nassau Bahamas
    Posts
    22

    Major Problem

    Hello guys im new to this club and im from The Bahamas. So im jus sayin hello. But I also have a problem with my impreza. Its sputterring and cutting off. I've changed the fuel filter, plugs and fill with fuel injector cleaner but no progress. But what I have noticed is that if I turn on the a/c the problem goes away whenever the compressor kicks in. The engine runs fine and smooth. When the compressor cuts out the problem comes back. Does anyone knows what the problem may be. Also there is no throttle response. When I press the pedal to the floor there is a flat spot, no engine revs or nothing. I hope someone understands me THANKS GUYS. oh and i have cleaned the throttle body as well.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    sounds like the injectors might be clogged
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  4. #3
    Registered User
    Join Date
    Mar 2008
    Location
    Nassau Bahamas
    Posts
    22
    Thanks for the quick reply guy. Ill get that checked out thanks. I hope I dont need new ones!!!!

  5. #4
    Banned
    Join Date
    Dec 2007
    Location
    New Jersey
    Posts
    327
    no, he said he cleaned the injectors, so i dont think it would be that. what year is the wrx... how long have you had it... does this happen RIGHT when you turn on the car?

  6. #5
    Registered User
    Join Date
    Mar 2008
    Location
    Nassau Bahamas
    Posts
    22
    Its A 1995, I just bought it saturday and yes it happens right when I turn on the car. Its a Japan Model.

  7. #6
    Banned
    Join Date
    Dec 2007
    Location
    New Jersey
    Posts
    327
    man i dont know. does the car start up at all. it could be like the spark plugs or battery

  8. #7
    Registered User
    Join Date
    Mar 2008
    Location
    Nassau Bahamas
    Posts
    22
    yes it starts then sputters for awhile then cuts off.

  9. #8
    Banned
    Join Date
    Dec 2007
    Location
    New Jersey
    Posts
    327
    i think then it is probably something wrong with the fuel system. could be bad injectors, but you said you cleaned them. try the fuel pump.

  10. #9
    Registered User
    Join Date
    Mar 2008
    Location
    Nassau Bahamas
    Posts
    22
    yea I think its a fuel problem too. because it cuts off as if it ran out of fuel. thanks guy when I changed the fuel filter the fuel came out black and dirty.

  11. #10
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    Quote Originally Posted by Bahamianwrx View Post
    Hello guys im new to this club and im from The Bahamas. So im jus sayin hello. But I also have a problem with my impreza. Its sputterring and cutting off. I've changed the fuel filter, plugs and fill with fuel injector cleaner but no progress. But what I have noticed is that if I turn on the a/c the problem goes away whenever the compressor kicks in. The engine runs fine and smooth. When the compressor cuts out the problem comes back. Does anyone knows what the problem may be. Also there is no throttle response. When I press the pedal to the floor there is a flat spot, no engine revs or nothing. I hope someone understands me THANKS GUYS. oh and i have cleaned the throttle body as well.
    Quote Originally Posted by rr1911 View Post
    sounds like the injectors might be clogged
    Quote Originally Posted by Teh Rexzor View Post
    no, he said he cleaned the injectors, so i dont think it would be that. what year is the wrx... how long have you had it... does this happen RIGHT when you turn on the car?
    yeah where does he say that in his post ?
    Quote Originally Posted by Teh Rexzor View Post
    i think then it is probably something wrong with the fuel system. could be bad injectors, but you said you cleaned them. try the fuel pump.
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  12. #11
    Banned
    Join Date
    Dec 2007
    Location
    New Jersey
    Posts
    327
    Quote Originally Posted by Bahamianwrx View Post
    Hello guys im new to this club and im from The Bahamas. So im jus sayin hello. But I also have a problem with my impreza. Its sputterring and cutting off. I've changed the fuel filter, plugs and fill with fuel injector cleaner but no progress. But what I have noticed is that if I turn on the a/c the problem goes away whenever the compressor kicks in. The engine runs fine and smooth. When the compressor cuts out the problem comes back. Does anyone knows what the problem may be. Also there is no throttle response. When I press the pedal to the floor there is a flat spot, no engine revs or nothing. I hope someone understands me THANKS GUYS. oh and i have cleaned the throttle body as well.

  13. #12
    Registered User Destros's Avatar
    Join Date
    Apr 2007
    Location
    Springfield, VA.
    Posts
    158
    Maybe MAP sensor. Clean your MAF sensor too. You throwing any codes?
    -created in the ominous shadow of The Great Vassar-
    Blobeye Syndicate #Eleventy-Seven

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •