excessive jumping when throttle engages?
+ Reply to Thread
Results 1 to 3 of 3

This is a discussion on excessive jumping when throttle engages? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i have an '02 WRX that is all stock with 158k miles on it. when i am in traffic at ...

  1. #1
    Registered User
    Join Date
    May 2006
    Location
    Utah
    Posts
    3

    excessive jumping when throttle engages?

    i have an '02 WRX that is all stock with 158k miles on it. when i am in traffic at speeds under 30 mph it seems to jump excessively right when i engage the throttle and a little bit when the throttle is released to coast. it happens mostly in 1st gear at midrange rpm's so around 10 - 15 mph. is this normal? if not, what might i need to check and/or fix?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,886
    I Support ClubWRX
    Search clutch recall.

    Check the throttle cabling and mechanism.
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User wrx0131's Avatar
    Join Date
    Jul 2007
    Location
    Yonkers, NY
    Posts
    1,385
    Quote Originally Posted by rycat_3 View Post
    i have an '02 WRX that is all stock with 158k miles on it. when i am in traffic at speeds under 30 mph it seems to jump excessively right when i engage the throttle and a little bit when the throttle is released to coast. it happens mostly in 1st gear at midrange rpm's so around 10 - 15 mph. is this normal? if not, what might i need to check and/or fix?
    Do you have a blow off valve on your car....because its alot more jerky at low speeds....i had the same problem.....or it could be that you are stepping on the gas too hard when you are going too slow

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •