Grinding Turbo Noise? What could it be?
Page 1 of 2 12 LastLast
Results 1 to 15 of 18

This is a discussion on Grinding Turbo Noise? What could it be? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hi guys. I've searched all over the internet to try and find out what is wrong with my car but ...

  1. #1
    Registered User
    Join Date
    Oct 2007
    Posts
    84

    Grinding Turbo Noise? What could it be?

    Hi guys. I've searched all over the internet to try and find out what is wrong with my car but just can't seem to find anything that fits the bill. Any input y'all could give would be super

    My car makes a grinding noise, in any gear/neutral, clutch in or out, at 3500 through 3750rpm. It starts exactly on the 3500 mark and stops exactly at the 3750 mark. It doesn't make the sound at 3400 or at 3800, just strictly between these two points, and it's a consistent sound. It is loud, audible from in and outside the car with no problem.

    It sounds as if I was taking a pencil and sticking it in a tiny encased plastic fan, not a roof fan but like an oscillating fan.

    Now for the variations:
    It doesn't do it when I first start the car in the morning. It will after about a minute but when the car is just first warming up for the day it won't do it.

    If I accelerate hard it won't make the sound going up, but when I shift it makes the sound as the tach comes back down.



    I'm at a loss right now, because I think my Blow off is causing the problem but my brother destroyed my stock bpv. Hammers, brothers and bpv's dont mix. I digress.

    I thought at first that it was compressor surge but the sound just didn't match up, and surge seemed more sporadic and this is constant to a tee.


    I appreciate any positive input, thanks ahead of time.
    Last edited by SilasJordan.USF; 02-17-2008 at 08:39 AM. Reason: mis-worded

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User WagonGuy's Avatar
    Join Date
    Sep 2005
    Location
    Chicago
    Posts
    585
    I don't have any solution for your problem primarily because I'm experiencing the same issue. In my case it happens exactly between 2500-2800 no matter if accelerating or decelerating rpms.

    It too sounds like very fast pinging, almost like valve pinging but slightly higher pitched and way too fast for valves.

    It happens after the engine is warmed up and usually after highway driving and not it doesn't depend on my driving style.

    My mods are simple (gutted uppipe, K&N drop in) and I only started noticing it after putting the K&N filter in.

    What are your mods?
    Blobeye Syndicate #1337
    man vs technology blog
    MvT@YouTube

  4. #3
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    stage 2 mods were in but this has me freaked out enough that I put the stock parts back on to see if it made a difference and I'm driving 99% stock (w/ gfb bov) with the stock map.

    I'm driving it stock to see if it makes a difference, it's been two weeks since I put them back in

  5. #4
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,004
    I Support ClubWRX
    Do you still have the stock turbo inlet?If you had a silicone aftermarket one it would be real easy to pull it off and use a mechanics mirror and a flash light to get a good look at the compressor wheel and see if you can find any damage to the wheel it self or if its making contact to the housing.Then pull off the downpipe and check the turbine side.Do you stilluse the stock EGT probe?If so check to make sure it hasn't broke off.For shats and giggles you could change the fuel filter,run some injector cleaner, and do the Seamfoam trick.I would run the Seamfoam off one of the inlet nipples so it cleans the compressor housing and TMIC as well as the rest of the intake tract.Also if you have a laptop I would suggest buying a Tactrix cable and datalog the car.Helps find problems like 10X easier.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  6. #5
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    inlet is stock, stock egt probe, and I have no idea what the seafoam trick is lol.
    I tried running injector cleaner but it did nothing.

    I do have a laptop but I have 0 knowledge of car tuning programs.

    what would I be looking for if I pulled off the dp and inlet?

  7. #6
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,590
    I Support ClubWRX
    Sounds like a heat shield rattling.

  8. #7
    Registered User WagonGuy's Avatar
    Join Date
    Sep 2005
    Location
    Chicago
    Posts
    585
    Quote Originally Posted by Trainrex View Post
    Sounds like a heat shield rattling.
    Since I have the same issue, I was considering it to be a valid source of the noise too. As a matter of fact when I did the uppipe I missed one or two screws for the heatshield (why so many of them originally? replaced since then) and it was rattling. Maybe one of them is lose, I'll have to check once the ice age goes away in Chicago.

    Other then that the car is running great, pulls strong, good mpg, no other weird sounds, no shaking, all liquids perfect, no leaks.

    SilasJordan.USF:
    Did you remove the snorkel on your car?
    Blobeye Syndicate #1337
    man vs technology blog
    MvT@YouTube

  9. #8
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    I had no clue my car came with a snorkel. sweet.

    But I'll be checking the heatshield tomorrow if its warmer. anything below 65 and I stay inside lol.

  10. #9
    Resident meany-rator 06wrx4me's Avatar
    Join Date
    Jun 2006
    Location
    Nor Cal
    Posts
    11,405
    I Support ClubWRX
    Is the BOV 100% VTA?
    2014 Ford Fiesta ST

    06 WRX, HAWKEYE # 001 <T-boned and sold>

    COILOVER TABLE
    TURBO TABLE

  11. #10
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    nope its hybrid. 50/50 :/

  12. #11
    Registered User WagonGuy's Avatar
    Join Date
    Sep 2005
    Location
    Chicago
    Posts
    585
    Quote Originally Posted by SilasJordan.USF View Post
    I had no clue my car came with a snorkel. sweet.

    But I'll be checking the heatshield tomorrow if its warmer. anything below 65 and I stay inside lol.
    Ohh wait...so you don't drive a Hummer? Funny guy!

    I meant the intake silencer. I have mine "deleted" but once the temps go up to a non life threatening levels I will put it back on to see if it maybe reduces the noise. If it does, then it's coming from the intake = no good.
    Blobeye Syndicate #1337
    man vs technology blog
    MvT@YouTube

  13. #12
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    Oh I didnt know that was a snorkel. My car lingo is limited lol.

    So I'm driving up to st pete for a seminar today, and along the ride I notice the noise stops. As soon as it did my car felt brand spankin new, from third it pulled like it was in second.

    Hopefully it's permanently remedied

  14. #13
    Registered User Beirne74's Avatar
    Join Date
    Oct 2007
    Posts
    5

    Same thing, maybe

    I have an '05 WRX and I am having the same or similar noise from around 3000 to 3500 rpms on acceleration and decceleration. No engine modifications on the car other than an STI high flow air filter. I was hoping it was the heat shield and not the turbo.

  15. #14
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    hmmmm.
    Well, my sound came back, but I go in for scheduled maint. tomorrow (15k checkup) and I'm gonna ask them.
    Last time the punks said they couldn't hear it; this time I'm not leaving till they unclog their ears

    I'll fill yall in on what it is as soon as i get back

  16. #15
    Registered User
    Join Date
    Oct 2007
    Posts
    84
    so it turns out that it is in fact the turbo, what is wrong with the turbo has yet to be discovered.

    Theyre gonna pull out my turbo wednesday and look at the turbine, supposedly it should have some shaft play and be grinding against its casing.

    Hopefully the oil restrictor pill caused it and not my b.o.v. so fixing it will be under warranty

    J.i.c I traded my buddy my gfb bov for the stocker.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •