>>>>The I smell raw gas from my WRX and its cold outside Thread (TSB inside)<<<< - Page 5
Page 5 of 10 FirstFirst 12345678910 LastLast
Results 61 to 75 of 148

This is a discussion on >>>>The I smell raw gas from my WRX and its cold outside Thread (TSB inside)<<<< within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Finally, a recall ! Thanks to all those who issued formal complaints over the last 8 years, and for those ...

  1. #61
    kjb
    kjb is offline
    Registered User
    Join Date
    May 2009
    Posts
    12
    Finally, a recall! Thanks to all those who issued formal complaints over the last 8 years, and for those who fought with SOA to get them to acknowledge their responsibility here. Best of luck to those who will attempt to get reimbursement for previous fixes.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #62
    Registered User
    Join Date
    Jan 2009
    Location
    chicago
    Posts
    7
    Quote Originally Posted by Destros View Post
    .
    where can i get that hose?

  4. #63
    Registered User Thomas1997's Avatar
    Join Date
    Dec 2009
    Posts
    8

    Try this easy fix first

    Tighten the fuel hoses with a philips. It worked on my wife's 02 outback.

  5. #64
    Registered User psychobooe's Avatar
    Join Date
    Mar 2004
    Location
    USAF
    Posts
    17
    This just started happening to me a couple weeks ago. I had heard of this problem so I wasn't really surprised or that concerned. However, my gas mileage is suffering about 3-4 mpg which is a concern. On cold start I can see fuel leaking under the inlet pipe. The car '02 WRX is registered in Florida and I live in Texas, but it was originally purchased in Colorado. I'm going to call the local dealership tomorrow and see what they say about getting it fixed.
    They have to fix it under warranty since it was originally purchased in Colorado right?
    Try not, do or do not. There is no try. - Yoda
    Mods

  6. #65
    Registered User MengHang's Avatar
    Join Date
    Jul 2003
    Location
    MI
    Posts
    300
    I have aftermarket parts in the engine bay. What do they remove for this fix?

    I have cold air intake, blow off valve, manual boost controller. Should I remove any of the items listed?

    Help. Thanx.

    Meng Hang

    Ogura Corporation (US Headquarters) Chesterfield Township, MI
    Network System Administrator, IT Supervisor
    Black WRX 2002, ...with 18G with Stock IC.

  7. #66
    Registered User vttk_mig69's Avatar
    Join Date
    Jan 2008
    Location
    Sheboygan, WI
    Posts
    527
    I gladly took my 02 in on friday and they changed out the passenger side fuel rail with a new one. I was a little fustrated though, they said it would take about 3 Hrs. to fix, and I was sitting there for a little over 5 Hrs. but I am a pretty patient person but still 5 hrs, I think i could have changed that faster.

    anywho all in all at least its fixed and I wont be nauseated by gas when I warm up my car in these cold wisconsin winters.

    To MengHang: I have the silencer delete and a boost gage and pod and they didn't say anything to me, but if your worried i would ask just incase, but i wouldn't think it would be a problem because you didn't mess with the fuel system and thats what they are fixing.

    just my $0.02
    Last edited by vttk_mig69; 01-17-2010 at 06:10 PM.

  8. #67
    Registered User teamsubaru04WRX's Avatar
    Join Date
    Nov 2009
    Location
    Pennsylvania
    Posts
    42
    Quote Originally Posted by 4cyturbowrx View Post
    Well i locked my keys in my car while it was running a good 45 mins and i think i smelt fuel when i got in......... I was kinda cold and couldnt really breath being sick........ The past couple of days we have been getting some 10 degree weather which is kinda low for my area.....
    im having the same problem with my 04WRX so i guess i will take it to ertle tuesday and see what they say... looking on here it looks like it will be pricey..

  9. #68
    Registered User teamsubaru04WRX's Avatar
    Join Date
    Nov 2009
    Location
    Pennsylvania
    Posts
    42
    Quote Originally Posted by Hold_Fast View Post
    I just got this two days ago. Started the car in 5 degree weather and in smelled for about 10 minutes then went away. I've also been getting some bad gas mileage too....

    I'm in a 04' WRX. So it looks like no fix for me. I'll have to take her to the mechanic.
    Hey its joe, brians friend i met you at the victory meet, this happened to me the other day when it was realy cold out.. It is still smelling though 4 days later, i think i will take it to the dealer this week, have not seen any gas leaking though...

  10. #69
    Registered User vttk_mig69's Avatar
    Join Date
    Jan 2008
    Location
    Sheboygan, WI
    Posts
    527
    Here is Wis we just had a week of pretty cold days like 0to5 degrees with a -10 to -15 wind chill and with my replaced fuel line i haven't smelled any gass at all and the car runs great so I'm happy with getting the recall work done. and my dealer was more than happy to fix it, no fuss or saying it didn't apply to my car just said bring it in and we will fix it.

    Lakeland Subaru of Sheboygan

  11. #70
    Registered User
    Join Date
    Oct 2009
    Location
    Cal Co, MD
    Posts
    68
    So i live in maryland which all of you know i'm sure isn't covered by the recall but i called the dealership closest to my house and asked about this problem. They told me to call S.O.A., so i did and they told me to schedule an appointment with the dealership to see what can be done. Ok... So i called subaru of annapolis back and scheduled an appointment, which was today. Well all in all they ended up telling me that it was the fuel line that was having the problem, ...DUH!. but to my surprise they said that even though maryland isn't covered by the recall i am still getting it fixed free because subaru issued an extended warranty on the fuel line and rail.

    So if you live in a state that isn't covered by the recall, give your local dealer a call and they'll most likely get it fixed for you.

    Oh yea i'll be getting it fixed next thursday.

    just letting you know my experience
    Last edited by mbrown44; 02-03-2010 at 02:49 PM.
    Bugeye Mafia #306

  12. #71
    Registered User
    Join Date
    May 2007
    Location
    Philly
    Posts
    70
    I've had the same issue all winter long so far. After I saw the recall for the other states, I decided to bring my subie to the dealership today to have them tell me what they could do.

    I'm glad I did because they are going to order the parts and repair it under warranty for me! I live in PA btw which isn't one of the states covered under the recall.

  13. #72
    Registered User MengHang's Avatar
    Join Date
    Jul 2003
    Location
    MI
    Posts
    300
    Just had mine done. Done in 3 hours. Nice job by Hodges Subaru in MI. They did not mind my intake, blow off valve, manual boost controller. No issues.
    Meng Hang

    Ogura Corporation (US Headquarters) Chesterfield Township, MI
    Network System Administrator, IT Supervisor
    Black WRX 2002, ...with 18G with Stock IC.

  14. #73
    Registered User
    Join Date
    Oct 2009
    Posts
    4
    Anybody get a CEL after the fuel line recall WVK21. I got one a few days after the fix. The dealer said that it was a loose fuel cap. He cleared the codes and now CEL has popped up again a day later. The tech's other insight was that I might have something going wrong with the head gasket which seems strange that it should come up right after I get the recall done and has not shown up previously. I do feel that the engine has been acting pretty sluggish since I got it back. Thoughts...insights.. comments ?

  15. #74
    Registered User MengHang's Avatar
    Join Date
    Jul 2003
    Location
    MI
    Posts
    300
    Quote Originally Posted by alitahir98 View Post
    Anybody get a CEL after the fuel line recall WVK21. I got one a few days after the fix. The dealer said that it was a loose fuel cap. He cleared the codes and now CEL has popped up again a day later. The tech's other insight was that I might have something going wrong with the head gasket which seems strange that it should come up right after I get the recall done and has not shown up previously. I do feel that the engine has been acting pretty sluggish since I got it back. Thoughts...insights.. comments ?
    Sound like they might have messed up. The guy who did my repair is also related to me. He says if the tech is not good, there will be issues. He's been working at subaru for years and knows the engine inside/out. It's known to take 5 hours for some shops, but he can do it in 3 hours.

    How long did it take for yours? Was yout tech experienced?

    note: I do have upgraded fuel injectors too. No issues.
    Meng Hang

    Ogura Corporation (US Headquarters) Chesterfield Township, MI
    Network System Administrator, IT Supervisor
    Black WRX 2002, ...with 18G with Stock IC.

  16. #75
    Registered User
    Join Date
    Oct 2009
    Posts
    4
    Quote Originally Posted by MengHang View Post
    Sound like they might have messed up. The guy who did my repair is also related to me. He says if the tech is not good, there will be issues. He's been working at subaru for years and knows the engine inside/out. It's known to take 5 hours for some shops, but he can do it in 3 hours.

    How long did it take for yours? Was yout tech experienced?

    note: I do have upgraded fuel injectors too. No issues.
    They actually took about a week...I dropped it off on a Tuesday and they started taking the car apart only to realize that they did not have one of the parts so had to order that for Friday delivery and completion of the job. On Friday the tech that was working on it had that car apart but was fired in the middle of the job as he had managed to lose another customer's car keys. They had another tech pick up where he left off and I got the car back on Monday last week. I got the first CEL on this Monday morning (1 week later) which I showed to them for that evening and they cleared that. The next one came up yesterday evening (1 day later).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •