Airbag Light Suddenly On
Results 1 to 7 of 7

This is a discussion on Airbag Light Suddenly On within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have an o4 WRX with stage 2 stuff done a couple years back. I recently (about 800 miles ago) ...

  1. #1
    Registered User
    Join Date
    Apr 2006
    Location
    Windsor, Ca
    Posts
    180

    Airbag Light Suddenly On

    I have an o4 WRX with stage 2 stuff done a couple years back. I recently (about 800 miles ago) changed the spark plugs and had to disconnect the battery. Now I've got an Airbag light stuck on. Is there a quick way to fix this, like taking the wires off the battery or something else before I take it to the dealer and they use stage 2 equip. to overcharge me?
    Blob Eye Syndicate #1000

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Micah's Avatar
    Join Date
    Oct 2005
    Location
    Ocean Grove, NJ
    Posts
    4,142
    http://legacygt.com/forums/showthrea...t=59503&page=2

    "Disconnected the battery...waited 10 minutes and then disconnected the main airbag wire under the dashboard/steering wheel, just like the manual said."

    worth a shot
    Torch Red 2002 Chevrolet Corvette Z06 46k mi.
    Black 2002 Subaru Impreza WRX 6-speed 94k mi. my mod list
    10/08/2006 - 14.089@103.01 (5-speed with well worn clutch, no launch)
    "Six stars gleaming, five speeds breaking, four tires chirping, three differentials working, two liters screaming, one turbo boosting... it's what makes a Subaru all-wheel-drive, all we'll drive."
    for Bugeye owners my BOV thread Service Manuals

  4. #3
    Registered User dowright82's Avatar
    Join Date
    Feb 2006
    Location
    Tennessee
    Posts
    224
    this happen to me a few months ago - turned out that it was just the airbag sensor cable under the driver/passenger seat that had come partly unplugged. Check 'em and make sure they're tight.
    SOLD: 2004 WR Blue WRX
    SOLD:2006 WR Blue Wrx - Perrin 25mm Front Sway + 22mm Rear Adjustable Sway and Kartboy Endlinks - Nitto Invo 225/45/17 - Opensource STG One.
    CURRENT: 2006 Legacy GT Limited - STOCK (for now)

  5. #4
    Registered User
    Join Date
    Apr 2006
    Location
    Windsor, Ca
    Posts
    180
    that was exactly it. the clip under my seat was slightly disconnected.
    Blob Eye Syndicate #1000

  6. #5
    Registered User
    Join Date
    Aug 2003
    Location
    Philadelphia, PA
    Posts
    225
    does anyone have pics of what the clips look like? I too have and 04 stage 2 and just today this silly light came up, I uesd my accessport to check for CEL Coeds but none were present.

    thanks!
    Rudy
    Power is nothing without control

  7. #6
    Registered User Yossarian's Avatar
    Join Date
    Jan 2006
    Location
    Ohio
    Posts
    2,142
    I noticed mine was on a few weeks ago. Didn't notice when exactly it turned off but it's not there anymore. Like most unpleasant things in life, it's best to just ignore it and hope it goes away.
    ~Selah

  8. #7
    Registered User
    Join Date
    Aug 2003
    Location
    Philadelphia, PA
    Posts
    225
    ^ haha thanks but with my MY00 and MY01 I had a CE light because of my mods... I'm not going back to having indicator lights shine'n at me if they can be avoided haha but thanks
    Power is nothing without control

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •