Help on CEL code P1086 - Tumble generator valve
Results 1 to 14 of 14

This is a discussion on Help on CEL code P1086 - Tumble generator valve within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So my 02 WRX wagon throws out the code P1086. Checked and found it is the: < Tumble generator valve ...

  1. #1
    Registered User black_knight's Avatar
    Join Date
    Mar 2007
    Posts
    17

    Help on CEL code P1086 - Tumble generator valve

    So my 02 WRX wagon throws out the code P1086. Checked and found it is the:
    < Tumble generator valve #2 (LH) position sensor circuit low input >

    Does anyone know where it is located and how to fix/replace it. It tried clearing the code but it does not happen.

    Thanks!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jan 2008
    Location
    houston texas
    Posts
    15
    Quote Originally Posted by black_knight View Post
    So my 02 WRX wagon throws out the code P1086. Checked and found it is the:
    < Tumble generator valve #2 (LH) position sensor circuit low input >

    Does anyone know where it is located and how to fix/replace it. It tried clearing the code but it does not happen.

    Thanks!
    i have the same cel code, i took it to dealer, they told me i need to replace the whole tgv, the sensor its on top left of your maniflow

  4. #3
    Registered User black_knight's Avatar
    Join Date
    Mar 2007
    Posts
    17
    Quote Originally Posted by celularhn View Post
    i have the same cel code, i took it to dealer, they told me i need to replace the whole tgv, the sensor its on top left of your maniflow
    Hey thanks, I did replace just the sensor and it solved the CEL code, thanks for your help!

  5. #4
    Registered User
    Join Date
    Jan 2008
    Location
    houston texas
    Posts
    15
    Quote Originally Posted by black_knight View Post
    Hey thanks, I did replace just the sensor and it solved the CEL code, thanks for your help!
    where did you get the sensor from, im been loking for one, and how much was it

  6. #5
    Registered User black_knight's Avatar
    Join Date
    Mar 2007
    Posts
    17
    Quote Originally Posted by celularhn View Post
    where did you get the sensor from, im been loking for one, and how much was it

    I got mine for 100 bucks..just for the sensor...
    Whcih side do you need and I can check if i have it...PM me with details

  7. #6
    Registered User
    Join Date
    Jan 2008
    Location
    houston texas
    Posts
    15
    Quote Originally Posted by black_knight View Post
    I got mine for 100 bucks..just for the sensor...
    Whcih side do you need and I can check if i have it...PM me with details
    i need sensor # 2 wich is the sensor on the driver side

  8. #7
    Registered User black_knight's Avatar
    Join Date
    Mar 2007
    Posts
    17
    Quote Originally Posted by celularhn View Post
    i need sensor # 2 wich is the sensor on the driver side
    I have the sensor from the pessanger side, don't know if they are interchangable though. The dealer was selling the whole TGV unit for over $300 i think, and did not separately sell the sensors...bummer!!
    If you can find the pessanger side works...then you'll be all set...

  9. #8
    Registered User
    Join Date
    Aug 2009
    Posts
    3

    code p1086

    hi i own a 2000 subaru wrx and got the same fault now do you think it might just be the sensor how easy is it to find one ,do you have a part number for that .Please help and also is it easy to replace or have to go to a mechanic

    thanks

  10. #9
    Registered User black_knight's Avatar
    Join Date
    Mar 2007
    Posts
    17
    Quote Originally Posted by rohan View Post
    hi i own a 2000 subaru wrx and got the same fault now do you think it might just be the sensor how easy is it to find one ,do you have a part number for that .Please help and also is it easy to replace or have to go to a mechanic

    thanks

    It was easy to replace it myself...I just had to replace the left one...but I still have a right one, but it is for a 2002 WRX...

  11. #10
    Registered User
    Join Date
    Aug 2009
    Posts
    3

    p1086

    hey thanks ,just are u able to give me a quick idea where its is located ..will be great thanks again

  12. #11
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176

  13. #12
    Registered User
    Join Date
    Aug 2009
    Posts
    3

    p1086

    thanks bro .. great

  14. #13
    Registered User
    Join Date
    Feb 2010
    Location
    spring hill fl
    Posts
    1

    this is great

    You guys are great with out this post I would have just replaced everything.

    Subaru does not sell this part by it's self (t.g.v sensor)

    thanks again.

  15. #14
    Registered User gogocricket's Avatar
    Join Date
    Jun 2011
    Location
    Grand Rapids, Michigan, United States
    Posts
    132
    I Support ClubWRX
    I also have a P1086. Also tried clearing it, to no avail. I read the thread on scooby mods; http://www.scoobymods.com/tgv-sensor...086-t5160.html

    I see that the description for code P1086 says "Tumble Generated Valve Position Sensor 2 Circuit Low"

    Where is sensor 2 located, by the turbo or the intake manifold?

    Does anyone know what a 'circuit low' code means as opposed to 'circuit high,' P1087? Does it make a difference regarding what needs to be done to fix the problem?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •