Problems
Results 1 to 6 of 6

This is a discussion on Problems within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I am new to the site and joined up hoping someone out there would be able to give me some ...

  1. #1
    Registered User Beirne74's Avatar
    Join Date
    Oct 2007
    Posts
    5

    Question Problems

    I am new to the site and joined up hoping someone out there would be able to give me some insight as to what is going on with my car. I have an '05 WRX and was on my way home the other night when the speedometer fell to zero and quit adding mileage on the odometer and tripometer. All other gauges are working. About 5 minutes later the check engine light comes on and the cooling fans start running wide open. The engine is fine, the fluids are fine. Turbo is working. In addition the car acts like it wants to shut down when if hits 5000 rpms. Any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Beirne74's Avatar
    Join Date
    Oct 2007
    Posts
    5

    The dealership

    I dropped off my wrx at the dealership this morning and they are claiming that it is the gear that runs the speedometer. In order to replace this they will have to drop the transmission, split the case, and replace the gear. They also claimed that the issue with it acting like it wants to shut down at 5000 rpms was because of the rev limiter. So I informed them that this wasn't the case unless the computer has limited the car to 5000 rpms because of what was happening to it and that I have the car past 5000 rpms on a daily basis. They said they will look into it further and claim that fixing the speedometer is going to solve the problem with the cooling fans too. What do you think?

  4. #3
    Registered User independent 68's Avatar
    Join Date
    Jul 2007
    Location
    Parker, Co
    Posts
    483
    thats pretty bizarre...dont really know what to tell ya man, ive never dealt with the limiter b4
    "Whatever it takes"

  5. #4
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    Sounds like the speed sensor. If the speed sensor gear shreds, it's an easy fix. If the gear that runs the speed sensor shreds, the trans has to be opened.

    And yes, the speed sensor will cause all of those problems.

  6. #5
    Registered User Beirne74's Avatar
    Join Date
    Oct 2007
    Posts
    5

    Thanks

    I was told it was the gear for the speed sensor. New one on me. Is this a common problem? I was just cruising in fifth gear in the middle of a downpour when it happened so it wasn't like I was pushing on the car.

  7. #6
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    Quote Originally Posted by Beirne74 View Post
    I was told it was the gear for the speed sensor. New one on me. Is this a common problem? I was just cruising in fifth gear in the middle of a downpour when it happened so it wasn't like I was pushing on the car.
    It does happen, but it's rather random. It's also not a Subaru specific part either. 99% of cars on the road today have speed sensors, and they do go bad. Either the magnetic pickup goes bad, or the little bearings seize up and shred the plastic gears. Most of the the gears are plastic so they shred. If they didn't shred, they would break off or possibly worse in the event of a failure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •