No Boost
Results 1 to 4 of 4

This is a discussion on No Boost within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; i have a 2003 subaru wrx impreza. for about a month now i have had no boost i have checked ...

  1. #1
    Registered User
    Join Date
    Jul 2007
    Posts
    3

    No Boost

    i have a 2003 subaru wrx impreza. for about a month now i have had no boost i have checked everything from checking to see if theres shaft play,taking my accessport looking for cel codes, resseting the ECU,making sure the restrictor pill was intact, the only thing i could think of is maybe my boost silenoid is bad. when im driving the vehicle i ca hear the sound of air coming from where the turbo sit but there is no exhaust leak so if there is anyone that has had this problem or has some anwsers would be greatly appreciated im a newbie to this so willing to try anything to fix this issue.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Thug Nasty's Avatar
    Join Date
    Jul 2006
    Location
    Denver CO / Portland OR
    Posts
    185
    what mods do you have?
    -John
    Different Strokes
    Dirty Crew #2002
    Mods in profile.

  4. #3
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0

  5. #4
    Registered User
    Join Date
    Jul 2007
    Posts
    3
    Quote Originally Posted by Thug Nasty View Post
    what mods do you have?
    i have hks helix downpipe full turbo back exhaust 3 in, samco intercooler hoses, k&n drop in with stock airbox, accessport v1 stage 2 tune 93 octane.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •