Mis-firing on all four cylinders HELP!!!!!!!!!!!
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 18

This is a discussion on Mis-firing on all four cylinders HELP!!!!!!!!!!! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a 02 WRX Wagon and everything is stock on the car. I scanned the car and it read ...

  1. #1
    Registered User
    Join Date
    Jan 2006
    Location
    Orange County CA
    Posts
    21

    Mis-firing on all four cylinders HELP!!!!!!!!!!!

    I have a 02 WRX Wagon and everything is stock on the car. I scanned the car and it read P0301,P0302,P0303, and P0304. It is mis-firing on all four cylinders.

    I replaced all four sparkplugs, and all four coil-packs, but still the light came back on. All four cylinder is still misfiring.

    Should I change the MAF sensor? It look kind of dirty and I clean it a couple of time already. The engine doesn't said any thing about the MAF sensor, so I'm not sure about changing it.

    At this point I don't know what to do any more, and the dealer is not really helping, they just start naming a bunch of things to replace.

    I also checked my Alternator, and it read 13.93 volts, I know that it a little below normal, so I'm thinking about replacing that too, but still I don't know what really cause it. HELP!!!!!!!!!!!!!!!!!!!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User big_sur's Avatar
    Join Date
    Sep 2006
    Location
    Goode, VA
    Posts
    46
    check your ground?

  4. #3
    Registered User
    Join Date
    Jul 2006
    Posts
    166
    Deff check your grounding

  5. #4
    DUB
    DUB is offline
    Registered User DUB's Avatar
    Join Date
    Jul 2007
    Location
    SLT, CA
    Posts
    3,176
    Change the plug wires too.

  6. #5
    Moderator Donkey's Avatar
    Join Date
    Apr 2005
    Location
    Da boonies
    Posts
    6,315
    I Support ClubWRX
    Quote Originally Posted by DUB View Post
    Change the plug wires too.
    OK..
    Check the gaps on the plugs( .032) and maybe put alittle dialectric grease in the coil pack plug tower.Are they the right plugs?13.8-14.4v is normal alt output.Did you do one plug at a time?You cannot get the wiring harness mixed up or the wrong cylinder will be firing.
    Resident Adviser @ WTF Tuning, LLC
    2002 FORESTER S
    1998 FORESTER S




  7. #6
    Registered User
    Join Date
    Jan 2006
    Location
    Orange County CA
    Posts
    21
    Quote Originally Posted by Donkey View Post
    OK..
    Check the gaps on the plugs( .032) and maybe put alittle dialectric grease in the coil pack plug tower.Are they the right plugs?13.8-14.4v is normal alt output.Did you do one plug at a time?You cannot get the wiring harness mixed up or the wrong cylinder will be firing.
    I replace all four plugs at the same time and all four coil packs at the same time. I got them from the dealership, so I'm assuming that it's the right one. Also the wire was plug back in correctly, black in the rear and white in the front. After that I reset the the engine light and it was fine for about 60 miles until the engine light came back up again. I was told that the only time that all four cylinder is misfiring is when you replace the fly wheel with a lighter fly wheel.

    I want to check my grounds wire, but I don't know where each one is located at, can any body tell me where? Also what about the MAF sensor, should I replace that?

  8. #7
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,641
    I Support ClubWRX
    Do you have an aftermarket crank pully?
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  9. #8
    Registered User
    Join Date
    Jan 2006
    Location
    Orange County CA
    Posts
    21
    Yes I do have an after market crank pulley, but I had it for about 2 years now, and everything was fine until now. Is that the problem?

    Also any body knows where all the grounds wires at?

  10. #9
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,641
    I Support ClubWRX
    Quote Originally Posted by thundersquid View Post
    Yes I do have an after market crank pulley, but I had it for about 2 years now, and everything was fine until now. Is that the problem?

    Also any body knows where all the grounds wires at?
    More than likely that's the problem buddy. I know it took 2 years to show up, but when you lighten either the pulley or the flywheel, it can cause the position sensor to think all 4 cyl's are misfiring.

    Besides the timing being retarded, does the engine feel like it's running smooth?
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  11. #10
    Registered User
    Join Date
    Jan 2006
    Location
    Orange County CA
    Posts
    21
    Most of the time it run pretty smooth, once in a while it spurted a little, with some awkward drop and rise in rpm of a couple hundreds. I figure that because it is running on limp mode due to the engine light.

  12. #11
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,641
    I Support ClubWRX
    if you have the stock pulley... I'd swap it out, and reset the ECU (if you have a cobb AP) or unplug the negative batt cable for like 5 minutes
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  13. #12
    Registered User
    Join Date
    Jan 2006
    Location
    Orange County CA
    Posts
    21
    Should I put back the stock pulley? will it be okay with out replacing the pulley with a OEM one?

  14. #13
    Registered User
    Join Date
    Jan 2006
    Location
    Orange County CA
    Posts
    21
    Okay I'll swap it back, but I need to find one, I misplace mine some where.

    Thanks

  15. #14
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,641
    I Support ClubWRX
    if you have it... I'd try the stock pulley... the performance gain from the pulley is less than the drop in performance from the retarded timing.. So that's the first thing I'd try.

    But hey.. it's up to you man. It seems like you've spent a lot of money to fix this problem so far.. and I'd put a week's paycheck that after all the stuff you've fixed, the pulley is probably the problem.
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

  16. #15
    UnBanned Sinister's Avatar
    Join Date
    Nov 2006
    Location
    Denver Metro Area
    Posts
    17,641
    I Support ClubWRX
    Quote Originally Posted by thundersquid View Post
    Okay I'll swap it back, but I need to find one, I misplace mine some where.

    Thanks
    if you're going to buy one, call tristan at thekingofparts.com they specialize in both oem and aftermarket parts. One of the few dealerships that actually are mod friendly.
    Kevin
    Moderator
    Sinister's Blowoff Valve FAQ
    WRX Gas Mileage FAQ
    Sinister's Progress Thread - 430whp 429wtq - Sold
    Firearms Enthusiasts Thread

    The Sheriff's Star at the bottom left corner rates a user's reputation.
    If you found a user's post to be helpful or quite the opposite, please make it known to them by clicking the Star!

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •