need help
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on need help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; hi everyone. im having a little trouble with my 02 wrx. it seems when the radiator fans come on they ...

  1. #1
    Registered User WRX7886's Avatar
    Join Date
    Oct 2007
    Posts
    33

    need help

    hi everyone. im having a little trouble with my 02 wrx. it seems when the radiator fans come on they make the engine shutter. i thought nothing of it until they made the car stall. the car only shutters when the fans come on if its in park or im sitting at a stop light. what i dont understand is that if im in park and leave the hood open the engine doesnt shutter as much. can anyone give me a idea of what could be wrong? or is this normal behavior for a wrx. i dont know what would be considered normal behavior since this is my first turbo.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User perfusionista's Avatar
    Join Date
    May 2004
    Location
    Boulder County, CO
    Posts
    378
    If you leave the shutters open then it should be cool enough that you don't need a fan...

    I'm sorry, you mean shudders, why didn't you say so? Sounds like your idle control's off, or maybe a dirty MAF sensor. When the fan comes on the tiny bit of extra load is just enough to drop it below safe idle speed. The bit about the hood is just confusing, though.

    BTW, welcome to the club. If you can take the abuse you'll find some good resources here.

  4. #3
    Registered User WRX7886's Avatar
    Join Date
    Oct 2007
    Posts
    33
    oops yeah thats what i meant lol. sorry about that. anyways how do i clean the maf sensor or turn on my idle control? sorry if those are noob questions but im kind of a noob. ive only owned my wrx for a few months now and ive only been driving for a couple of years.
    ive been learning as i go but subarus are so reliable that i havent had the chance to learn that much. im hoping to benefit from the knowledge of all the people on this forum. so far i have learned alot searching through these threads. like just the other day i had my oil changed and the dealership told me that my cabin air filter needed to be changed and they wanted 125 dollars for it. so i googled how to change it and thats how i found this forum and i did it myself yesterday for 30 dollars.

  5. #4
    ODJ
    ODJ is offline
    Registered User ODJ's Avatar
    Join Date
    Jan 2006
    Location
    Tampa, FL
    Posts
    357
    Do a search on "MAF cleaning" and you'll find some good threads with pictures. The procedure isn't that difficult, but the screws tend to strip so be careful.

    I'm not sure about your idle problems, but if your fans are coming on a lot, then you should make sure your car has the proper amount of coolant and that there are no air bubbles trapped in the system.

    The level in the coolant reservoir will rise quite a bit when the car is warm, but it should still be up to the FULL line when the car is completely cold (after sitting overnight, perhaps).

    Also, take off your radiator cap and give the hose right behind it a squeeze to see if any air bubbles up out of the open radiator.
    UNSPOILT BY PROGRESS

  6. #5
    Registered User WRX7886's Avatar
    Join Date
    Oct 2007
    Posts
    33
    Quote Originally Posted by ODJ View Post
    Do a search on "MAF cleaning" and you'll find some good threads with pictures. The procedure isn't that difficult, but the screws tend to strip so be careful.

    I'm not sure about your idle problems, but if your fans are coming on a lot, then you should make sure your car has the proper amount of coolant and that there are no air bubbles trapped in the system.

    The level in the coolant reservoir will rise quite a bit when the car is warm, but it should still be up to the FULL line when the car is completely cold (after sitting overnight, perhaps).

    Also, take off your radiator cap and give the hose right behind it a squeeze to see if any air bubbles up out of the open radiator.
    the fans dont come on alot its just when they do come on it makes it idle really rough and it feels and sounds like its gonna stall. other than that it runs perfect. also i forgot to mention that i only have 38k miles on it. not sure if thats important information or not.
    so far through all my searching the best answers i got was maybe a leak in one of the hoses (which seems to make sense) and your reply and the other persons reply. ill try searching about the maf cleaning thing though and im gonna try what you said about squeezing the hose too. thanks for the help.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •