'04 WRX won't shift out of park...
+ Reply to Thread
Results 1 to 8 of 8

This is a discussion on '04 WRX won't shift out of park... within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Hey guys, I'm new to this forum, and new to the car world. I just bought an '04 WRX, and ...

  1. #1
    Registered User Tr1s7an's Avatar
    Join Date
    Sep 2007
    Location
    Upstate New York
    Posts
    21

    '04 WRX won't shift out of park...

    Hey guys,

    I'm new to this forum, and new to the car world. I just bought an '04 WRX, and I love it. It has been sitting at my house for a couple of weeks, because I need to strip off the straight pipe exhaust (Put the cats back on, so it will pass inspection) I came back home from school the other night tried starting the car, and it wouldn't turn over, so I spun the key again, and it started. Went to put the car into Drive (It's an automatic by the way), and the shifter knob wouldn't move out of park, I tried forcing it just to see if it was stuck, but to no avail. The car shifts into Reverse, and can drive in reverse if you hold the shifter in the "R" position. So, getting frustrated, I shut the car off, and tried to pull the key out of the ignition, and it wouldn't come out. So, now I have a perfectly good car sitting in my driveway, with the key in the ignition, and no way of putting the vehicle into drive. Does anyone have ANY ideas as to what could be the issue? Any help would be greatly appreciated. Thanks.

    -Tr1s7an

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    is the key stuck because you left it in R?

    I have no idea why it won't go into drive did you not have your foot on the brake?
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  4. #3
    Registered User Tr1s7an's Avatar
    Join Date
    Sep 2007
    Location
    Upstate New York
    Posts
    21
    No, I had to force it into reverse, and then it snaps right back into park...and yeah...my foot was on the break. lol

  5. #4
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    Quote Originally Posted by Tr1s7an View Post
    No, I had to force it into reverse, and then it snaps right back into park...and yeah...my foot was on the break. lol
    haha i am out of ideas then
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  6. #5
    Registered User efmd3's Avatar
    Join Date
    Jun 2006
    Location
    the ham
    Posts
    9,158
    Quote Originally Posted by Tr1s7an View Post
    No, I had to force it into reverse, and then it snaps right back into park...and yeah...my foot was on the break. lol
    brake

    and is there a CEL?

  7. #6
    Registered User Tr1s7an's Avatar
    Join Date
    Sep 2007
    Location
    Upstate New York
    Posts
    21
    Yeah, there is a CEL, but it has been up since I bought it as it needs a new O2 sensor.

  8. #7
    Registered User efmd3's Avatar
    Join Date
    Jun 2006
    Location
    the ham
    Posts
    9,158
    Quote Originally Posted by Tr1s7an View Post
    Yeah, there is a CEL, but it has been up since I bought it as it needs a new O2 sensor.
    so nothing involving the transmission?
    check the linkage and if you can't see anything ask someone who knows a lot about auto trannies...

  9. #8
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,939
    Have you had any problems with the transmission prior to this? It could be something stuck inside, it could also be the plate on your shifter linkage has rotated. IN order to check it you're going to have to get the car up in the air and look under it on the drivers side of the transmission.

    Also, the only transmission code that can be thrown is a speed sensor CEL which would toss your car into limp mode with a redline around 3-3.5K.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •