Tumble Generator???
Results 1 to 10 of 10

This is a discussion on Tumble Generator??? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Got code 1088 and 1090. P1090 Tumble generator valve #1 (RH) malfunction (stuck open) and P1088 Tumble generator valve #1 ...

  1. #1
    Registered User
    Join Date
    Aug 2006
    Posts
    21

    Tumble Generator???

    Got code 1088 and 1090. P1090 Tumble generator valve #1 (RH) malfunction (stuck open) and P1088 Tumble generator valve #1 (RH) position sensor circuit low input. Any ideas on what's going on or how I can fix that. Or if it's a major problem. Got 03 Impreza WRX. It drives the same when I first got it. Just wondering what I need to do. Thanks for any help.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,275
    I Support ClubWRX
    What were you doing when it happened?

    Mods?

    Seen this?
    http://forums.nasioc.com/forums/show...mble+valve+cel

    or seen this?
    http://forums.nasioc.com/forums/show...mble+valve+cel
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User
    Join Date
    Aug 2006
    Posts
    21

    d

    Those Threads help but the only problem I have is that I don't even know what the Tumble Generator is, where it's located, or what it looks like. It kicked on completely after I put an STI exhaust on the car. I haven't messed with under the hood at all. From what the guys are talking on the Nasi forums it's an easy fix. Lemme know guys.

  5. #4
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Quote Originally Posted by zerowrx View Post
    Those Threads help but the only problem I have is that I don't even know what the Tumble Generator is, where it's located, or what it looks like. It kicked on completely after I put an STI exhaust on the car. I haven't messed with under the hood at all. From what the guys are talking on the Nasi forums it's an easy fix. Lemme know guys.
    +1 What is a tumble generator

  6. #5
    Registered User
    Join Date
    Aug 2006
    Posts
    21

    a

    Hahaha!! You got me. I'm looking at an 04 STI service manual. And it identifies what the Tumble Generator Valve Assembly looks like and where it is located. Will this be about the same for my 03 Subaru WRX. Same torque specs and such?

  7. #6
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,907
    Quote Originally Posted by zerowrx View Post
    Those Threads help but the only problem I have is that I don't even know what the Tumble Generator is, where it's located, or what it looks like. It kicked on completely after I put an STI exhaust on the car. I haven't messed with under the hood at all. From what the guys are talking on the Nasi forums it's an easy fix. Lemme know guys.
    It's an extension of the intake manifold which goes into the heads on your car. . . the piece that your injectors go into. I would start by looking for loose wiring, it could just be an unplugged motor.

    Are you the first owner of your WRX?

  8. #7
    Registered User
    Join Date
    Aug 2006
    Posts
    21

    a

    I do believe the second owner. Car has been modified before I got it. I'm going to look at the wiring and such going to it. It just sorta randomly happened one day with the check engine light. It'd go off and come back one occasionally but it finally came on for good.

  9. #8
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,907

    A good pictures of of APS' website where you can see the STi intake manifold with the TGV's bolted to it. On the lower right hand side of the screen you can see an unplugged sensor right above the word intake. I can't remember if there are four motors or just two but you need to locate those and verify they are plugged in on your car. it is possibl that one of them is stuck or has died.

  10. #9
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,275
    I Support ClubWRX
    From what you've written it's likely someone sometime knocked something loose. If it were a single CEL I'd be more suspicious of a failure, but since you're getting two fault codes I'd look for bad workmanship before anything else.
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  11. #10
    Registered User
    Join Date
    Apr 2005
    Location
    Brooklyn, NY
    Posts
    39
    bored at work and i figured i'd give my 2 cents. from what i remember from reading the service manual. tumble gererators are a couple sticks that swirl the air for better low end torque. the units are located between the manifold and the head. from what i remember the diagram. its controlled via vacuum / boost not sure how it works. but a solinoid will open letting vacuum / boost move a plunger type motor. so check for vacuum hoses loose. also there is a sensor that checks to see the position of the tumble generator. make sure that everything is connected.. let us know... whats up.
    - one word; Thunder cougar falcon bird.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •