Backfiring for some reason
Results 1 to 11 of 11

This is a discussion on Backfiring for some reason within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; I have a 2003 WRX with a few mod's - aTurboXS engine managemnt sytem, up pipe, down pipe and exhaust, ...

  1. #1
    Registered User
    Join Date
    May 2003
    Location
    Asheville, NC
    Posts
    66

    Backfiring for some reason

    I have a 2003 WRX with a few mod's - aTurboXS engine managemnt sytem, up pipe, down pipe and exhaust, a K&N Typhoon short ram and Turbo XS blow off valve. It has run fine for years. Now in the last couple of weeks it has started to backfire when lifting off after medium strong acceleration. I thought maybe some bad gas but this has continued through 3 tanks now. Any ideas? Thanks. JacksonWRX

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ZACK777's Avatar
    Join Date
    Sep 2007
    Location
    Cincinnati, OH
    Posts
    1,368

    missing/backfire

    Ive have the same problem 04 wrx misses and backfires anytime I give it more than half throttle. have a couple mods CCAI BOV Im sort of new to the subaru/AWD scene so any help would be greatly appreciated.

  4. #3
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    The noob's are gathering

    You guys both have what

    BOV FTW!!!!!

    The BOV's are making your cars run rich in between shifts and were never made to be put on a subaru. Why you ask. The mass air flow sensor in the car lacks in performance compared to other turbo charged cars such as SRT-4 and Evo's who have MAP(manifold absolute pressure) type sensor.

    Take them off and sell them for other parts or the original part. Or don't I don't care. But that is your answer.

  5. #4
    Registered User
    Join Date
    May 2003
    Location
    Asheville, NC
    Posts
    66
    I supppose it is fair to ask since the blow off valve has been on the car from the beginning (along with everything else) and it didn't backfire for 4-1/2 years, why now is it a problem? JacksonWRX

  6. #5
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    you had the full exhaust and BOV and didn't back fire at all?

    If all you have is the BOV and stock exhaust then instead of back firing through your catless exhaust it would just Fup your cats in the exhaust
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  7. #6
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    I don't know! There is far to little information for me to determine. Mod list help. Have you resently gone cat less.
    The Bov HAS been making your car run rich no doubt in my mind.

    It might have come out of adustment. I'm no expert on the things. Because they serve no purpose. And frankly they irritate me.


  8. #7
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    Quote Originally Posted by Not-EWRX View Post
    I don't know! There is far to little information for me to determine. Mod list help. Have you resently gone cat less.
    The Bov HAS been making your car run rich no doubt in my mind.

    It might have come out of adustment. I'm no expert on the things. Because they serve no purpose. And frankly they irritate me.

    take a chill pill bro
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  9. #8
    Banned
    Join Date
    Jun 2007
    Location
    Great Salt City of Utah
    Posts
    0
    Quote Originally Posted by xMDxWRX View Post
    take a chill pill bro

    Anger.


    Fart

  10. #9
    Registered User xMDxWRX's Avatar
    Join Date
    Jan 2006
    Location
    Towson MD
    Posts
    1,337
    Quote Originally Posted by Not-EWRX View Post

    Anger.


    Fart
    i guess that works
    2004 VW GLI "Back In Boost "

    Quote Originally Posted by KanoWRX View Post
    well...IMO, or IMI (In My Imagination) WRX's/STi's are still better that Evo's...hands down...despise the facts.........

  11. #10
    Registered User Yossarian's Avatar
    Join Date
    Jan 2006
    Location
    Ohio
    Posts
    2,142
    running a bov with the stock turbo is lame, troof
    ~Selah

  12. #11
    Registered User Black X Dahlia's Avatar
    Join Date
    Apr 2008
    Location
    baton rouge, la
    Posts
    417
    a BOV is bad for a stock wrx/sti, and isnt required when tuned under 20psi+. Read up
    How Fast Can You Afford To Go?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •