Blinking CEL
Results 1 to 5 of 5

This is a discussion on Blinking CEL within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Yea... so I was driving home from eating at a restaurant and all of a sudden my CEL starts blinking ...

  1. #1
    Registered User delusionz's Avatar
    Join Date
    Jan 2006
    Posts
    29

    Blinking CEL

    Yea... so I was driving home from eating at a restaurant and all of a sudden my CEL starts blinking on me and occasionally it'll just stay lit and then start blinking again. My car shakes like there's an earthquake and the car just runs like complete garbage. It feels like the car is about to explode. I pop the hood and EVERYTHING is shaking like crazy. I've checked bits and pieces of other threads and I know everyone is probably gonna tell me its misfiring and I'm going to get the code tomorrow but can anyone tell me if this is like REALLY REALLY bad? cause the car won't stop rumbling and it's scaring the crap out of me considering that ever since I got this car (used) i've already had to do an engine swap due to a blown motor, a new clutch, suspension, etc etc. I only have an exhaust and I just changed the o2 sensor recently. could an error in changing the o2 sensor cause this too? any help at all is appreciated and about how much do u think the damages will be

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Jul 2006
    Posts
    166
    sounds like a misfire to me

  4. #3
    Registered User SubyPsycho's Avatar
    Join Date
    Apr 2005
    Location
    PA
    Posts
    546
    Quote Originally Posted by nsvwrx View Post
    sounds like a misfire to me
    +1

  5. #4
    Registered User
    Join Date
    Jun 2007
    Location
    eprov rhode island
    Posts
    200
    for it to be shaking as violently as you claim im willing to bet you are going to have a tumble generator valve code...its not likely to have such a violent misfire..and as far as the o2 sensor..no it wouldnt violently misfire from that...it is possiblle but very unlikely you have a multiple misfire .if it is the tumble generator valve then its going to be a costly repair...aproximately 900 bucks anyway good luck
    New England F4

    feel free to pm me with any questions..

  6. #5
    Registered User delusionz's Avatar
    Join Date
    Jan 2006
    Posts
    29
    got it checked out today it was a P0103. Mechanic told me it was about time the car got a tune up so he changed the air filter, fuel filter, and spark plugs. Car is running fine now :whew:

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •