URGENT: Need Help
Results 1 to 3 of 3

This is a discussion on URGENT: Need Help within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok, not quite sure where to begin so bare with me, i have a 2002 WRX that has been modified ...

  1. #1
    Registered User
    Join Date
    Dec 2006
    Posts
    3

    URGENT: Need Help

    Ok, not quite sure where to begin so bare with me, i have a 2002 WRX that has been modified quite a bit. When i bought the car from a friend the following mods were already done....

    MRT Turbo Back Exhaust
    MRT Top Mount Intercooler
    GFB Blow Off
    Catless Downpipe
    Exedy Clutch
    Lightened Fidenza Flywheel

    I think that about covers what was done to the car before i got it. Didn't have any issues at all except for an occasional cel for catelyst deficency due to the catless downpipe. A few months down the road my stock turbo seized due to the precat in the up-pipe becomming dislodged and throwing shards into the turbo..... Here is where i started modding. I replaced the turbo with a slowboy racing 16G turbo, and i also gutted the precat in the up-pipe to prevent any more mishaps. Due to this upgrade i was getting multiple EGT cel's so there fore i removed the EGT sensor and bypassed it with a 2.2K resistor, solving that problem. I then upgraded the injectors to STI Pinks, a walbro fuel pump, Wideband O2 sensor as well as a Turbo XS Delta Piggy back unit. I had the car protuned shortly after. Since I have done those upgrades i am getting multiple CEL's for misfire on all cylinders. I was informed quite a few times that it was due to the lightened flywheel. Doesn't really make any sense due to the fact i never had a misfire code before i did my upgrades. Either way this brings me to my problem at the moment....I was on my way home yestersay when there was very loud POP, which i am assuming was really bad backfire. To make a long story short, i ended up having to have the car towed back home. When i got home i changed the spark plugs to the NGK iridium's. All four of the old plugs were black as can be and fouled out. When i started the car afterwards it is still running really rough, and it smells of gas really bad. I was thinking maybe the timing jumped, but i don't know for sure. If anyone has any ideas on anything please PM me and give me any advise that you may have, it would greatly be appreciated. Thanks,

    Wes

    Ok, just got done with a compression test. all four cylinders check out ok, between 140 and 150 on all four.
    Last edited by Wes1525; 08-18-2007 at 11:17 AM. Reason: forgotten text.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator
    Join Date
    Apr 2002
    Location
    Greenville, SC
    Posts
    2,081
    My first step would be to check your crankshaft and camshaft position sensors. All too often folks will forget to plug those back in, since they're a bit hidden. Make sure they're tight.

    Next I'd go ahead and bite the bullet, and tear it down to the timing belt. This engine is super-sensitive to being off by even 1 tooth. I have a hard time seeing it jumping, but I suppose if you're still on the original belt and running a bunch more power, it's possible.

    Beyond that, I've got to guess that your pros messed up your tune. I'd take it to another shop for a re-eval.
    2002 WRX Sedan - 2000 Mazda Miata
    Do us all a favor: work on learning how to drive your car before adding more power. Pretty please.

  4. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    3
    ok the car has been tuned for about 3 1/2 months now and it was running well, besides the CEL for the misfire due to the flywheel. I did call them after this happened and they said that it sounds as if there was a hose on the pressurized side of things that might of popped off. after a quick look i didn't see anything out of the ordinary. I still need to rip off the intercooler to see if there isn't anything under there that might of come loose. If worse comes to worse i will completely rip off the timing cover and check that out. If there is any other suggestions please come forward, any advise will help, might be something small that i am overlooking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •