They broke my bolts!
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 16

This is a discussion on They broke my bolts! within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok let me start this off with ERRRRRRR. God dam subaru. Ok so Im installing my Down pipe right now ...

  1. #1
    Registered User kram941's Avatar
    Join Date
    Jul 2005
    Location
    wilmington, MA
    Posts
    175

    They broke my bolts!

    Ok let me start this off with ERRRRRRR. God dam subaru.

    Ok so Im installing my Down pipe right now and Im at the point of disconnecting the DP from the turbo and there it is...a bolt wit no head...looks like the people at subaru snapped it while they were installing it(unless its suppose to be like this) Well i hope it would come losse while i removed the nut but it didnt. Anyone have any suggestion on how to remove it? ill keep loadin it up wit WD40 while I wait for a response lol.

    EDIT: there are two bolts on the turbo like this!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User UR MOTHA's Avatar
    Join Date
    Dec 2001
    Location
    Fountain Valley, CA
    Posts
    767
    I think you're referring to the studs, they are supposed to be that way. 3 bolts will go into the turbo, 2 nuts will go onto the studs on the turbo.

  4. #3
    Registered User WRX13oy's Avatar
    Join Date
    Jul 2003
    Location
    SOCAL!! 91752
    Posts
    6,979
    Quote Originally Posted by UR MOTHA
    I think you're referring to the studs, they are supposed to be that way. 3 bolts will go into the turbo, 2 nuts will go onto the studs on the turbo.
    +1 if its on the turbo
    SOCAL F4#02 OG member

    2002 PSM WRX stage 6
    2007 Kawasaki Ninja ZX6R

  5. #4
    Registered User WRX13oy's Avatar
    Join Date
    Jul 2003
    Location
    SOCAL!! 91752
    Posts
    6,979
    if its these 2 on the turbo. they are suppose to be there
    SOCAL F4#02 OG member

    2002 PSM WRX stage 6
    2007 Kawasaki Ninja ZX6R

  6. #5
    Registered User UR MOTHA's Avatar
    Join Date
    Dec 2001
    Location
    Fountain Valley, CA
    Posts
    767
    Quote Originally Posted by WRX13oy
    if its these 2 on the turbo. they are suppose to be there
    showoff

  7. #6
    Registered User WRX13oy's Avatar
    Join Date
    Jul 2003
    Location
    SOCAL!! 91752
    Posts
    6,979
    Quote Originally Posted by UR MOTHA
    showoff
    WORD! haha
    SOCAL F4#02 OG member

    2002 PSM WRX stage 6
    2007 Kawasaki Ninja ZX6R

  8. #7
    Registered User kram941's Avatar
    Join Date
    Jul 2005
    Location
    wilmington, MA
    Posts
    175
    haha few....thought i got totally screwed over

  9. #8
    Registered User speeddr2000's Avatar
    Join Date
    Mar 2005
    Location
    jacksonville
    Posts
    284
    so u didnt did relize it was a sud when u pulled a nut off it ? or was there no nut on it ?

  10. #9
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,936
    Aren't there 3 studs on the turbo?

  11. #10
    Registered User kram941's Avatar
    Join Date
    Jul 2005
    Location
    wilmington, MA
    Posts
    175
    Quote Originally Posted by speeddr2000
    so u didnt did relize it was a sud when u pulled a nut off it ? or was there no nut on it ?
    I thought it was like the other two and it was a nut and a bolt so i thought the bolt head was broken off

  12. #11
    Registered User kram941's Avatar
    Join Date
    Jul 2005
    Location
    wilmington, MA
    Posts
    175
    Yea there was three studs on the turbo.


    finally got the DP installed took wayyyy to long lol... 2 hours to remove the bolt holdin it the to transmision. Had to cut the bracket the remove bolt it was so stuck. Just one leak tho caust i cant get the DP and exhaust to line up good enough(dam ebay) but gunna thro another gasket in there and that should do it.

  13. #12
    Registered User speeddr2000's Avatar
    Join Date
    Mar 2005
    Location
    jacksonville
    Posts
    284
    did u tighten up the bolts in the right order there is an order i think is up to turbo then down pipe but i would check. if u dont tighten in the order u get a leak common problem.

  14. #13
    Registered User kram941's Avatar
    Join Date
    Jul 2005
    Location
    wilmington, MA
    Posts
    175
    So whats the correct order? I know i have a leak where the DP meats the rest of the exhaust...

  15. #14
    Registered User PolarisSnT's Avatar
    Join Date
    Aug 2002
    Location
    Staten Island, NY
    Posts
    3,864
    Yea I could swear there are 3 studs on the turbo and the only two bolts are on teh top that hold the heat shield bracket.

    As for the OP, did you install just the downpipe? Then there really isnt a correct order. The order that was spoken of a couple posts up refers to the uppipe installation.
    Dan- 2004 PSM 5spd

    "Days get shorter, nights get longer, snow gets deeper, life gets better."

  16. #15
    Registered User psychobooe's Avatar
    Join Date
    Mar 2004
    Location
    USAF
    Posts
    17
    When the Subaru dealership replaced my clutch (because of the shudder), they cross thread one of the bolts. I had to cut the damn thing off. Thankfully it was one of the bolts and not the studs.
    Try not, do or do not. There is no try. - Yoda
    Mods

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •