P0304 Cylinder Misfire Code on my stock 04 wrx
Results 1 to 5 of 5

This is a discussion on P0304 Cylinder Misfire Code on my stock 04 wrx within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; like the title says i have gotten 2 p0304 Cylinder misfire codes....these came on strangely as i started the car ...

  1. #1
    Registered User bluej20's Avatar
    Join Date
    Jun 2004
    Posts
    147

    P0304 Cylinder Misfire Code on my stock 04 wrx

    like the title says i have gotten 2 p0304 Cylinder misfire codes....these came on strangely as i started the car this morning...the only odd thing that i can remember is that i used some 2 gallons of 100 octane race gas a couple of tanks ago. Im stumped.
    Should i take it to the dealer...i have just gotten out of my warranty at 37000 miles.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User bluej20's Avatar
    Join Date
    Jun 2004
    Posts
    147
    UPDATE:

    well i am not really stock...i had the 3/16 th mod. Had a AirHOG filter and a chopped intake silencer jug. So frustrated i first un did the 3/16th mod (i was spiking upto 15.5 psi in each gear) i just went to pep boys and put in a 1/8th connector and some new vaccum hose....then i reset the ECU....

    Killed the power by disconnecting the battery...stepping on the brake 5 times and letting the car sit for 35 mins disconnected.

    Powered her back on let her idle for about 10 mins so she can re learn her idle. Than procedded to the gas station bought some injector cleaner and then took it on a 150 mile long drive the next day...

    its been 200 miles now and NO CEL thankgod.

    I hope it doesnt come back.

  4. #3
    Registered User
    Join Date
    Sep 2004
    Location
    West of the Mississippi
    Posts
    125
    update?

  5. #4
    Registered User bluej20's Avatar
    Join Date
    Jun 2004
    Posts
    147
    Quote Originally Posted by j*bishop View Post
    update?
    Well i sold the car on Jan 29th.. with 49520 miles and never got the CEL again during this thread and the sale of the car.

  6. #5
    Registered User
    Join Date
    Sep 2004
    Location
    West of the Mississippi
    Posts
    125
    aaahh no worries. thx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •