CEL Irony
Results 1 to 3 of 3

This is a discussion on CEL Irony within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; My 2003 WRX Wagon (stock, no mods) has 43,000 miles on it and is ready to be turned in off ...

  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    1

    Red face CEL Irony

    My 2003 WRX Wagon (stock, no mods) has 43,000 miles on it and is ready to be turned in off lease. The car had its pre return inspection last week (passed without any problems) and I drove it home and parked it afterwards. Sunday I started it up to move it and the CEL came on (at first solid, then blinking) and the engine was running rough. The car has never had any problems until 2 weeks before I turn it in off lease (and out of warranty). Its going to the dealer tommorow . Any suggestions?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator MidKnight's Avatar
    Join Date
    Oct 2002
    Location
    Bergen, NJ
    Posts
    4,711
    I Support ClubWRX
    Get the cel code pulled and report back to us. That's the only way we can help...
    '03 WRX
    '01 2.5RS
    MODS | PICS | Dyno
    "Stuff sold by the gram is always going to be more exciting than stuff sold by the pound." - Jeremy Clarkson

  4. #3
    Registered User amukaoen's Avatar
    Join Date
    Apr 2004
    Location
    Aurora, IL
    Posts
    1,429
    The most common CEL I think that happens out of the blue, would be the...

    gas cap not on properly CEL... it happend to me and I freaked out, luckily I figured out what it was... popped the gas cap off, and retightend it. drove around for about 5-6 mins and the CEL disssappered.
    they call STi's STDs because everyone is getting them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •