Fog Light Malfunction?!?
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 25

This is a discussion on Fog Light Malfunction?!? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; 3 times!!!! this is the 3rd time since i got my car in August. I bought my 2004 wrx used ...

  1. #1
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088

    Fog Light Malfunction?!?

    3 times!!!! this is the 3rd time since i got my car in August. I bought my 2004 wrx used this august. the right fog light was out when i bought it. i replaced the bulb and it worked for a month. end of sept and i had to change the same bulb again. i was driving to work next to my brother tonight and he told me my fog light was out again!!! keep in mind i've never hit anything hard enough to knock a bulb out or rattle it loose. i love my rex, but is this a popular problem? searched a bit and but couldnt find much of anything useful to my specific problem. anyone have some info? thank you.
    -mike
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    any info guys? or is it just me?
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  4. #3
    Registered User Skreekin's Avatar
    Join Date
    May 2005
    Location
    Bellingham, WA
    Posts
    1,582
    Maybe it is just you. I have been driving with my fogs on everyday for the past 7 months and they still work great. Have you checked the seals on the backside of the light housing and made sure that its all clean and seals well? Either that or have you been buying cheap replacement bulbs for it?
    2005 WRB WRX Stage 2
    Blobeye Syndicate #76
    A Must Read http://www.clubwrx.net/forums/engine...do-not-do.html

  5. #4
    Registered User DJSHADOW7's Avatar
    Join Date
    Aug 2005
    Location
    AZ
    Posts
    2,675
    Never had a prob. with mine....

    Good luck man.
    ...If you ever need anything please don't hesitate to ask someone else first.

    Blobeye Syndicate numero uno.

  6. #5
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,933
    Hmph, now that I think of it mine burnt out as well. Right about 20K miles.

  7. #6
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    my bro had picked up the bulbs for me. the 1st time it went he had stopped to pick em up and he got me a few. that could be it. maybe my bulbs are just cheap i'll go buy some new ones tomorrow and see what happens. the seals are nice and tight, no leaks or anything. i'll go with this and see what happens. thanks guys.
    -mike
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  8. #7
    Registered User ynotajb's Avatar
    Join Date
    Sep 2004
    Location
    mmmm,, tater salad
    Posts
    2,711
    i had one of mine blow out once,,, now I have foglight covers so I dont even know if they still work .. .
    dude one time i tried to put the trailer bully into the coiler, and I got all messed up

  9. #8
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    changed out the bulb again today. hope all goes well this time. went to work tonite and my friend with a 05 wrx (not on the forums) was complaining his went out yesterday.. hope i'm good to go this time
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  10. #9
    Registered User PolarisSnT's Avatar
    Join Date
    Aug 2002
    Location
    Staten Island, NY
    Posts
    3,864
    My fogs have blown about 3-4 times in the 48k miles Ive had my car. I usually just buy a cheap bulb and replace it but now Im waiting for one to die again cause I have these sweet H3 Luminics bulbs that I got from Subaruwrxparts.com Ill let you know how they work out. Did you touch the actual bulb during the install? I know with the headlights being as powerful as they are, getting first and oil on the bulb will decrease their life. Maybe its the same with the fogs.
    Dan- 2004 PSM 5spd

    "Days get shorter, nights get longer, snow gets deeper, life gets better."

  11. #10
    Registered User vincent77's Avatar
    Join Date
    Nov 2005
    Location
    Lansing MI
    Posts
    0

    Bad bulbs

    Mine have went out at least 3 times in the past year and a half and i always buy the nice expensive ones, the dealership has never figured out why but now i put them in myself because of the oil on bulb problem
    "I can resist everything except temptation."
    www.subarunited.com
    www.dirtyimpreza.com
    www.corruptmotors.com

  12. #11
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    since my last post in this thread, my fog has went out another 2xs. its only the passenger side everytime. i set up an appointment with my dealer for tuesday. hope this resolves my problem for good.
    -mike
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  13. #12
    Registered User cannibal869's Avatar
    Join Date
    Jun 2003
    Location
    Marina Del Rey, CA
    Posts
    467
    sounds like perhaps a wiring / voltage problem?
    Good luck.
    Chris
    '04 PSM WRX Sedan
    Blobeye Syndicate #8

  14. #13
    Registered User lonedw86's Avatar
    Join Date
    Aug 2004
    Location
    Ashland, PA
    Posts
    616
    My mom has the same problem on her 03 legacy. The dealer had fixed it like four times.

  15. #14
    Registered User ASPEN524's Avatar
    Join Date
    Aug 2005
    Location
    Jersey Shore
    Posts
    1,088
    i hope after tuesday, it'll be the last time i see this problem. i love my rex and this is my only complaint since ive owned it, but its gotta stop.
    -mike
    HAD: 2004 WRX
    MODS: http://www.clubwrx.net/forums/showth...01#post1478901

    HAVE: 2002 BMW 323CI Coupe

  16. #15
    Registered User Woody182's Avatar
    Join Date
    Mar 2004
    Location
    Chicago, IL
    Posts
    167
    Mine did it once at about 11000 miles
    2004 WRB WRX
    Interior: Momo shifter knob, door sills, red bulbs on HVAC, fog light, keyring, clock
    Exterior: OEM spoiler, sideskirts, red brake calipers (G2 set), cleared headlights (all white), Blue "i" emblem
    Tint: 30% front/side 20% back
    Audio: Kenwood MPV 7019 head unit w/ mp3 adapter
    Power: OEM SPT catback exhaust system, K&N air filter

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •