CEL and fuel cut at 5k rpms
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on CEL and fuel cut at 5k rpms within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; So ive noticed my CEL commin on which i thought was bc of my catless dp but it seems to ...

  1. #1
    Registered User
    Join Date
    Apr 2005
    Location
    glen cove
    Posts
    52

    CEL and fuel cut at 5k rpms

    So ive noticed my CEL commin on which i thought was bc of my catless dp but it seems to go away when i put gas in my car. The car began to choke at around 4500rpms and fuel cut at 5k. Check engine light is off but car is still choking at 5000. Ive taken off my ssqv and put back on the stock bypass valve and its a little better, the car hesitates really bad and chokes out tho(it starts at around 4500). One thing ive noticed tho is that i can bring it up to redline on partial throttle, and my boost is spiking at 18-19psi in first, and around 17-18 in 2nd and third. I have a TBE so boost creep is expected but i think my car is just keeping my car from blowing up. Anyone? SOMEONE HELP ME!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User BlkWRXWag's Avatar
    Join Date
    Jan 2003
    Location
    Trabuco Canyon, CA
    Posts
    2,236
    Do you have a MBC?

  4. #3
    Registered User
    Join Date
    Apr 2005
    Location
    glen cove
    Posts
    52
    nope, no mbc, stock turbo

  5. #4
    Registered User BlkWRXWag's Avatar
    Join Date
    Jan 2003
    Location
    Trabuco Canyon, CA
    Posts
    2,236
    Check your hoses - sounds like one of the wastegate hoses came off.

  6. #5
    Registered User
    Join Date
    Apr 2005
    Location
    glen cove
    Posts
    52
    k are they gonna be like rubber hoses by the wastegate? can u explain to me what to look for?

  7. #6
    Registered User Redline927's Avatar
    Join Date
    Jun 2004
    Location
    New Jersey
    Posts
    3,516
    Quote Originally Posted by joelax4
    k are they gonna be like rubber hoses by the wastegate? can u explain to me what to look for?
    yes, check out all hoses by the turbo....was the car previously modded?

    are you sure no MBC? sounds like you have PTFB (partial thottle full boost) issues or something.

  8. #7
    Registered User
    Join Date
    Apr 2005
    Location
    glen cove
    Posts
    52
    nope no mbc, car was stock, and im not havin trouble with partial boost its when im WOT

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •