airbag light
Results 1 to 3 of 3

This is a discussion on airbag light within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; just changed my spark plugs today not all that hard to do when you have the right tools but after ...

  1. #1
    Registered User talonboost18psi's Avatar
    Join Date
    Jul 2005
    Location
    WElls Maine
    Posts
    63

    Question airbag light

    just changed my spark plugs today not all that hard to do when you have the right tools but after i changed the plugs I test drove the car it ran great. shut the car off. started it up like 4hrs later and the airbag light is on and I even reset the ECU and it is still on. any one have this problem or no what chould of caused this to happen in my 04 wrx with 55000 miles on it?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User SicWRX37's Avatar
    Join Date
    Apr 2005
    Location
    Charlotte, NC
    Posts
    641
    I dont really know how changing your plugs could be related to the airbags. Maybe there was something that was disconnected in the process of you changing your plugs. You might just want to take it into the dealer and have them take a look see.

  4. #3
    Registered User talonboost18psi's Avatar
    Join Date
    Jul 2005
    Location
    WElls Maine
    Posts
    63
    yah I was thinking that but I have a few mods that the dealers would not like and I dont want to take of all my **** enless I have to but thanks any way

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •