Coolant temp sensor location??
Results 1 to 10 of 10

This is a discussion on Coolant temp sensor location?? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Need a little help here guys... I've been searching all over the net for the answer to this. Legacy forums ...

  1. #1
    Registered User
    Join Date
    Nov 2003
    Location
    Chicago, IL
    Posts
    108

    Coolant temp sensor location??

    Need a little help here guys...

    I've been searching all over the net for the answer to this. Legacy forums are pretty much nonexsistant. I'm working on a friend's 95 Subaru Legacy and it had a CEL. Pulled the code and it's supposedly the coolant temp sensor. I've been nosing around the engine bay and I can't figure out where the heck the thing would be. I don't want to buy a service manual for this car since I'm only working on it once and I figure that the 2.2L boxer motor in this car is similar to the 2.0L in the WRX....anybody know where the heck this coolant temp sensor might be located???

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Banned 05WRX0704's Avatar
    Join Date
    May 2005
    Location
    Defense Language Institute, Monterey, CA
    Posts
    2,953
    well on my protege it was inside the hose at the engine block. remove from engine block and you would find the sensor there...

  4. #3
    Banned 05WRX0704's Avatar
    Join Date
    May 2005
    Location
    Defense Language Institute, Monterey, CA
    Posts
    2,953
    here it is, i believe, and if im correct it might help
    Attached Thumbnails Attached Thumbnails DSCN1368.JPG  

  5. #4
    Registered User ScoobVee's Avatar
    Join Date
    Mar 2004
    Posts
    1,900
    Quote Originally Posted by 05WRX0704
    well on my protege it was inside the hose at the engine block. remove from engine block and you would find the sensor there...
    Geeze, if we had a rep points system here, you'd be pretty much in the hole right about now
    - Local Riceist

  6. #5
    Registered User
    Join Date
    Nov 2003
    Location
    Chicago, IL
    Posts
    108
    Quote Originally Posted by 05WRX0704
    here it is, i believe, and if im correct it might help

    That's a thermostat...temp sensor is different (screws in a has a black harness I believe)...thanks for the effort though
    03 350Z - intake, test pipes
    Best STOCK E.T. 13.68@102.77mph 2.09 60'
    Best mods E.T. 13.38@103.60mph 1.90 60'

  7. #6
    Banned 05WRX0704's Avatar
    Join Date
    May 2005
    Location
    Defense Language Institute, Monterey, CA
    Posts
    2,953
    dammit thats what i was thinking about, sorry

  8. #7
    Banned 05WRX0704's Avatar
    Join Date
    May 2005
    Location
    Defense Language Institute, Monterey, CA
    Posts
    2,953
    does this help
    Attached Thumbnails Attached Thumbnails Untitled-1.jpg  

  9. #8
    Banned 05WRX0704's Avatar
    Join Date
    May 2005
    Location
    Defense Language Institute, Monterey, CA
    Posts
    2,953
    or this?
    Attached Thumbnails Attached Thumbnails Untitled-2jpg.jpg  

  10. #9
    Banned 05WRX0704's Avatar
    Join Date
    May 2005
    Location
    Defense Language Institute, Monterey, CA
    Posts
    2,953
    last one
    Attached Thumbnails Attached Thumbnails Untitled-3.jpg  

  11. #10
    Registered User
    Join Date
    Nov 2003
    Location
    Chicago, IL
    Posts
    108
    yes...thank you...I had a feeling it would be under the intake manifold....dammit. I've got some work to do.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •