wierd check engine
Page 1 of 2 12 LastLast
Results 1 to 15 of 20

This is a discussion on wierd check engine within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Arite, I've only had the rex for 2 weeks so im not 100% familiar with all its irregularites, but twice ...

  1. #1
    Registered User
    Join Date
    Apr 2005
    Posts
    10

    wierd check engine

    Arite, I've only had the rex for 2 weeks so im not 100% familiar with all its irregularites, but twice its thrown a check engine, both times on long high ways drivin over 45 mins. When I reset the ECU it clears the check engine. Its probably not EEC. current mods, intake, uppipe, and blow off. Any ideas?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User lilaznbro's Avatar
    Join Date
    Sep 2004
    Location
    chandler, az
    Posts
    256
    alot of ppl get thrown codes once they go for after market intakes, sensitive MAF sensor
    [-victor-]

  4. #3
    Registered User Hot_Dog's Avatar
    Join Date
    Jan 2003
    Location
    Albuquerque, NM
    Posts
    1,329
    Take it to autozone (or another store like that) and get the code pulled, then you'll know for sure what it is.
    2003 WRB Sedan. Mods & Pics

    Quote Originally Posted by scooby-x
    OMG!!! Do you want me on my knees or bent over? I love you

  5. #4
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    get rid of your intake and bov. those are the worst two mods to start with.

    dR

  6. #5
    Registered User
    Join Date
    Apr 2005
    Posts
    10
    I really think its a MAF sensor code, but its tight in there and fitment isnt a problem, maybe it shakes around too much... btw, there's nothing wrong with the bov and intake, those are perfectly fine initial mods, I wish I had a damn scanner already.

  7. #6
    Registered User IHRTWRX's Avatar
    Join Date
    Mar 2005
    Location
    NOR CAL
    Posts
    944
    Did anyone else catch the fact that he has an uppipe? That is probably the problem. There is a sensor in the uppipe for the cat. And if you have a catless uppipe you will throw a CEL.

  8. #7
    Registered User IHRTWRX's Avatar
    Join Date
    Mar 2005
    Location
    NOR CAL
    Posts
    944
    Quote Originally Posted by XITruthIX
    I really think its a MAF sensor code, but its tight in there and fitment isnt a problem, maybe it shakes around too much... btw, there's nothing wrong with the bov and intake, those are perfectly fine initial mods, I wish I had a damn scanner already.
    There isnt much wrong with the mods besides the fact that they do nothing to increase performance. In fact they may actually decrease performance a little. But hey at least it sounds cool right?

  9. #8
    Registered User
    Join Date
    Apr 2005
    Posts
    10
    well the BOV really doesnt do much, the intake gave me a nice boost of power in my top end tho, and yea man, they sound way cool. The only sensor in the up-pipe is an EGT sensor, which is a silly place for it to be anyway because the computer should be more concerned with post- turbine temperatures rather than pre-turbine temperatures which is half the reason the mod is so popular, but as long as the mod is done correctly that shouldnt throw any lights, the ecu doesnt use EGT to determine A/F or anything too important, still cant figure it out....

  10. #9
    Registered User perfusionista's Avatar
    Join Date
    May 2004
    Location
    Boulder County, CO
    Posts
    378
    Hey, dude, if dark_rex tells you something listen, don't contradict. Capisce?

  11. #10
    Registered User IHRTWRX's Avatar
    Join Date
    Mar 2005
    Location
    NOR CAL
    Posts
    944
    Quote Originally Posted by XITruthIX
    well the BOV really doesnt do much, the intake gave me a nice boost of power in my top end tho, and yea man, they sound way cool. The only sensor in the up-pipe is an EGT sensor, which is a silly place for it to be anyway because the computer should be more concerned with post- turbine temperatures rather than pre-turbine temperatures which is half the reason the mod is so popular, but as long as the mod is done correctly that shouldnt throw any lights, the ecu doesnt use EGT to determine A/F or anything too important, still cant figure it out....
    Well I ran TBE catless for about 1k miles and no CEL, then installed catless up and what do you know a CEL within 100 miles. I am sure i am not the only one. I have heard of this happening to other people but maybe not with just the uppipe. And one more thing pre turbo should be more important shouldnt it? I mean where does the turbo put that hot air? Back into the motor. Right? right.

  12. #11
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    Scan code, fix problem, end of story.

    If you don't want to do that, just assume it was the CEL fairy, and she's pissed at you. As long as you keep posting about it, and speculating, she won't come back.

  13. #12
    Moderator
    Join Date
    Jul 2003
    Location
    Maryland
    Posts
    11,098
    I Support ClubWRX
    Cold air intake, BOV, catless up pipe, and it sounds like he bought a modded wrx....I can only wonder why you have a CEL
    0-60 faster then your first sexual experience.
    "You've come far, and though you're far from the end
    You don't mind where you are, cause you know where you've been"

  14. #13
    Registered User
    Join Date
    Apr 2005
    Posts
    10
    hey hey hey... watch how you talk to me like that. aside from being ASE Master Certified I have a Masters in Auto Engineering with special emphasis on performance design. So if you havent taken a block of solid aluminium and crafted it into a working engine WITHOUT a CNC (pics on request), dont contradict anything I say cuz IMO, you dont stack up

    Check engine hasnt come back since resetting ECU, but then again I havent taken any lengthy trips with a constant RPM so we'll see, other wise its running great, I should've gotten a WRX YEARS ago

  15. #14
    Administrator Trainrex's Avatar
    Join Date
    May 2003
    Posts
    26,591
    I Support ClubWRX
    Quote Originally Posted by XITruthIX
    hey hey hey... watch how you talk to me like that. aside from being ASE Master Certified I have a Masters in Auto Engineering with special emphasis on performance design. So if you havent taken a block of solid aluminium and crafted it into a working engine WITHOUT a CNC (pics on request), dont contradict anything I say cuz IMO, you dont stack up

    Check engine hasnt come back since resetting ECU, but then again I havent taken any lengthy trips with a constant RPM so we'll see, other wise its running great, I should've gotten a WRX YEARS ago
    I'm sorry we don't stack up, but I do have one question. When you went through your ASE certification, didn't they teach you to scan the code before an ECU reset?

  16. #15
    Boba Fett BrianH's Avatar
    Join Date
    Oct 2003
    Location
    Way up high.
    Posts
    17,927
    Quote Originally Posted by XITruthIX
    hey hey hey... watch how you talk to me like that. aside from being ASE Master Certified I have a Masters in Auto Engineering with special emphasis on performance design. So if you havent taken a block of solid aluminium and crafted it into a working engine WITHOUT a CNC (pics on request), dont contradict anything I say cuz IMO, you dont stack up

    Check engine hasnt come back since resetting ECU, but then again I havent taken any lengthy trips with a constant RPM so we'll see, other wise its running great, I should've gotten a WRX YEARS ago
    YOu're an ASE master certified mechanic and haven't scanned the code yet?

    Where'd I put my lollerskates.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •