"Loose Gas Cap" CEL
Results 1 to 9 of 9

This is a discussion on "Loose Gas Cap" CEL within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; Ok...I have done some mods to my 02 wrx wagon and I have been getting a CEL for Loose Gas ...

  1. #1
    Registered User Nick4592's Avatar
    Join Date
    Jan 2004
    Location
    Denver Colorado
    Posts
    198

    Question "Loose Gas Cap" CEL

    Ok...I have done some mods to my 02 wrx wagon and I have been getting a CEL for Loose Gas Cap for some time now...I flash it and to no evail it always comes back no matter how tight I put the cap on. I did install the walbro fuel pump and STI pinks but that is all I have done with the fuel system...I am curious where I could be losing pressure to cause this CEL.
    "Life's a bowl of punch so go ahead and spike it!" -311

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,495
    I Support ClubWRX
    One possibility is actually the gas cap. See that the little seal surface is OK. In this case your mods aren't linked to the CEL.

    Alternatively, your mods are linked to the CEL. This means you may have a loose fitting at some line or that whatever you are using to control fueling/timing/boost is triggering a CEL (in other words, your EM could be a source).

    Checking the installation after doing a fuel pump swap is boring but might be a decent way to pass an hour or so. Are the fittings tight? Did you knock anything loose? What about the vent line and the filler?
    WRX Info Links, Courtesy TheJ
    The world breaks everyone and afterward many are strong in the broken places. Ernest Hemingway
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User Nick4592's Avatar
    Join Date
    Jan 2004
    Location
    Denver Colorado
    Posts
    198
    I just checked the seals around the fuel pump and made some more with silicone. I also have got a new gas cap....I did however make my own Manuel boost controller...do you think that could be it.
    "Life's a bowl of punch so go ahead and spike it!" -311

  5. #4
    ClubWRX.net Vendor
    Join Date
    Jul 2004
    Location
    City of Industry, CA
    Posts
    199
    try this, we had this happen with a 1.8T golf, once the light comes on for a gas cap, to get the light off, you have to start the car drive around the block, then shut off and then start againa nd drive around and then shut off and then restart and drive around again

    basically you have to shut down and start and drive around 3 times, i dont know if it works on the subaru, but thats how you fix it on the golfs, because even if you reset the ecu, the light still stays on utnil you drive it around
    SIX Autoworks ph. 626-820-0212
    Danny C. E-Mail: danny@sixautoworks.com AIM: SIX Autoworks
    16518 E. Gale Ave.
    City of Industry, CA 91745
    Mon. - Fri. 10am - 7pm PST Sat. 12pm - 4pm PST
    We accept Visa/Mastercard/American Express/Discover and other payments.

  6. #5
    Registered User Nick4592's Avatar
    Join Date
    Jan 2004
    Location
    Denver Colorado
    Posts
    198
    I drive a lot with that CEL...and it just stays...damn thing won't go away for SHEIT
    "Life's a bowl of punch so go ahead and spike it!" -311

  7. #6
    Mace Windu devilfluff's Avatar
    Join Date
    Feb 2005
    Location
    south jersey
    Posts
    6,274
    I Support ClubWRX
    Post the code #, not all evap codes are caused by a loose gas cap... there are several other possibilities...
    Dirty Jersey
    Part-Time Grammar Nazi
    RIP- '02 PSM Wagon
    08 Candy White MK5 GTI 6spd

    Moderator:Tri-State and Transmission & AWD forums

  8. #7
    Registered User Nick4592's Avatar
    Join Date
    Jan 2004
    Location
    Denver Colorado
    Posts
    198
    I'll post the code on tuesday when I get tuned cause I have to clear the CEL anyway....the code is for "check gas cap" though don't know if that will help with any ideas in the mean time
    "Life's a bowl of punch so go ahead and spike it!" -311

  9. #8
    Registered User 20wrx02's Avatar
    Join Date
    Oct 2002
    Location
    South East Mass
    Posts
    669
    oh boy-- another one.... i posted many times about this problem, i know 3 people with the same problem in my area-- and 2 of them are stock-- subaru replaced the gas cap still a cel. check the evap tank its fine... I have had the gas cap cel when i was stock but now im running stage2.5 cobb with a street tuner-- you are not going to pass inspection with a code....

    get it pressured checked -- if all else fails get a turner and elimate the code

  10. #9
    Registered User Nick4592's Avatar
    Join Date
    Jan 2004
    Location
    Denver Colorado
    Posts
    198
    Quote Originally Posted by 20wrx02
    oh boy-- another one.... i posted many times about this problem, i know 3 people with the same problem in my area-- and 2 of them are stock-- subaru replaced the gas cap still a cel. check the evap tank its fine... I have had the gas cap cel when i was stock but now im running stage2.5 cobb with a street tuner-- you are not going to pass inspection with a code....

    get it pressured checked -- if all else fails get a turner and elimate the code

    yeah....I have started the look into getting my own "CEL reflashing" gizzmo. WTF might as well
    "Life's a bowl of punch so go ahead and spike it!" -311

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •