Should I be worried about this?
Results 1 to 3 of 3

This is a discussion on Should I be worried about this? within the General Maintenance, Troubleshooting & Accidents. forums, part of the Tech & Modifying & General Repairs category; After changing the oil for the 1st time on my WRX the oil light came on briefly. Is this something ...

  1. #1
    Registered User
    Join Date
    Sep 2002
    Location
    New Jersey
    Posts
    12

    Should I be worried about this?

    After changing the oil for the 1st time on my WRX the oil light came on briefly. Is this something I should be worried about or will this always occur? Note: I've checked for oil leaks and every thing seems fine. Also, I've started the car up and driven it like 40 miles since and the oil light has not lit up again.

    Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User PlatinumWRX's Avatar
    Join Date
    Jul 2001
    Location
    PA
    Posts
    6,581
    PERFECTLY NORMAL

    The oil must be repressurized and the sensor was dry.

    -Jim

  4. #3
    Registered User NJSubieTech's Avatar
    Join Date
    Nov 2001
    Location
    Hamden, CT/Teaneck, NJ
    Posts
    397
    The first place that new oil goes from the pump is into the filter. If you fill the filter with oil before you start the engine, the light wont come on at all (maybe for a milisecond).

    Its not absolutely necessary, but I always do it, and if you choose to - youll have to fill it, let the filter absorb, and then fill again, etc.

    Speed safely,

    Joe
    merlin916@aol.com
    "Damn.... this car is wicked fast..." ~ My roomate, owner of a supercharged/intercooled 97 Trans AM
    Mods |

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •