2004 ( 04 '04) foglight ( fog ) bulb replacement - Page 2
Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

This is a discussion on 2004 ( 04 '04) foglight ( fog ) bulb replacement within the Exterior and Appearance forums, part of the Tutorials & DIY category; Originally Posted by Trailboss I did this today, using the method posted with pictures. It didn't take longer than 15 ...

  1. #16
    Registered User PlatinumWRX's Avatar
    Join Date
    Jul 2001
    Location
    PA
    Posts
    6,581

    Thumbs down

    Quote Originally Posted by Trailboss
    I did this today, using the method posted with pictures. It didn't take longer than 15 minutes, start to finish. It's very simple.
    Thanks for leaving me with burnt out fog lights, boss! Fortunately, I noticed before I took it in for inspection. These bulbs are WAY harder to replace than the bug eye design.

    -Jim (new owner of Trailboss' car)

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User blahblah's Avatar
    Join Date
    Sep 2003
    Location
    Chi-cago
    Posts
    816
    anyone with a fmic try this. im going home this weekend and am gonna put some bulbs in. Just wonderin if the piping gets in the way.

    ps. its a txs fmic so the pipes are on the bottom unlike the perrin
    282 AWHP...267 lb-ft torque.
    2005 WRB WRX Sedan

    "he's a domestic fan with a hunger for rice"

  4. #18
    Registered User 04SlvrWRX's Avatar
    Join Date
    Mar 2007
    Posts
    4
    damn rivets are a pain in the a$$...more like pain in the fingers though =[ but i got it done....That's a gay thing to do by subaru making it hard for us so they get money from it...

  5. #19
    Banned
    Join Date
    Aug 2007
    Location
    Portland, ME
    Posts
    195
    sorry to raise this thread from the dead but i noticed that someone put in the 100 watt h3's in instead of the recommended 55 watt. are there any detrimental effects from doing that? lower bulb life? (i also noticed that the bulbs were shot when the car ws sold )

    thanx for any info!

  6. #20
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,238
    I Support ClubWRX
    Quote Originally Posted by 04silver bullet View Post
    I found easiest to do it from underneather the car during an oil change. I didn't have remove anything from the car except the skid pan and the bulb. And I already had the skid pan off to change the oil. Easier your way though if you don't feel like jacking up the car, but I do suggest doing them during an oil change.

    --Jay--
    This is the way I did them on my 04 STi. "Can I get a reacharound?"
    tEh PriUs=teH faSTah!@@!
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  7. #21
    Registered User colorado_okie's Avatar
    Join Date
    Aug 2006
    Posts
    204

    Easy as pie

    I did this just the other day. Was really pretty easy! Pulled the front cover off, dropped the plastic shield/cover/gizmo-thingamajig, and viola!!! New light bulbs= working fog lights!!!
    Thanks!!!
    Randy
    Proud owner of an '04 Scoobie 'Rex San Remo Red
    '62 International Harvester Scout 80
    '96 Pierce Saber Rescue-Pumper
    '99 Pierce Dash 100' Platform ladder
    ***Blobeye Syndicate #951***

  8. #22
    Registered User
    Join Date
    Jan 2007
    Location
    Yankee Land
    Posts
    77
    Thanks for the info OP, this gave me something to do on Presidents Day.
    04 wrx wagon D/D
    02 S2K Summer Fun (sold)

  9. #23
    Registered User
    Join Date
    Apr 2008
    Location
    seattle
    Posts
    2

    awesome write up

    So I am more of a Ducati gearhead and just use my WRX to go fast in the snow, but I just bought the Piaa ion (Yellow) replacement bulbs and they kick ass.. thanks for the love by posting that super easy process up, 25 min for me and that included shop vacing out all the leaves stuffed in and around the front clip of my ride...


    Thanks again
    Danimal
    VP Desmo Northwest

  10. #24
    Registered User ctsrex's Avatar
    Join Date
    Apr 2009
    Location
    Columbus
    Posts
    58
    thanks for the info i ran into this problem today with my 05. stupid manual hahahahaha

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •