OLM LED Bulb Failure
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on OLM LED Bulb Failure within the Exterior & Appearance forums, part of the Tech & Modifying & General Repairs category; I'm not sure what's going on over at OLM headquarters, or if my WRX is an LED bulb killer, but ...

  1. #1
    Registered User strudinox's Avatar
    Join Date
    Nov 2010
    Location
    Longmont, CO
    Posts
    1,064
    I Support ClubWRX

    OLM LED Bulb Failure

    I'm not sure what's going on over at OLM headquarters, or if my WRX is an LED bulb killer, but as of now I've gone through 4 OLM LED 5W replacement bulbs. I'm tempted to complain to SubiSpeed, which is where I bought them, but honestly I don't want more of these bulbs as a replacement if this is a common thing. Is anyone else having this sort of problem, or am I alone in this one?

    here's a pic as to how they fail, and it's pretty consistent every time. Almost all of the LEDs will be off when plugged in except for one or two which will be VERY dim. Sorry for the terrible quality, It was late...

    Last edited by Sasquatch; 06-01-2015 at 02:43 PM.
    ...BECAUSE RALLY CAR

    Current Build: 2015 WRX Premium - WRB - Stage 2

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User GT800's Avatar
    Join Date
    Jan 2014
    Posts
    276
    Ive always gone with cheap leds planning to replace them but I did have diode dynamics bulbs in my turbo veloster and they were great. Had one start flickering they replaced it no question asked

  4. #3
    Registered User strudinox's Avatar
    Join Date
    Nov 2010
    Location
    Longmont, CO
    Posts
    1,064
    I Support ClubWRX
    I'll have to look into those, since I'm likely not going back to OLM after this.
    ...BECAUSE RALLY CAR

    Current Build: 2015 WRX Premium - WRB - Stage 2

  5. #4
    Registered User GT800's Avatar
    Join Date
    Jan 2014
    Posts
    276
    Dont blame you.

  6. #5
    Registered User bdonaldd84's Avatar
    Join Date
    Apr 2015
    Location
    Bakersfield, Ca
    Posts
    66
    I had to wiggle my olm's but mine were blinking. Now mine work. But honestly I think I would have saved money by ordering on amazon instead. I have heard some going with the Sylvania LEDs

  7. #6
    Registered User strudinox's Avatar
    Join Date
    Nov 2010
    Location
    Longmont, CO
    Posts
    1,064
    I Support ClubWRX
    I tried wiggling them and it didn't seem to help. I suppose they could have been blinking before they failed completely without me knowing.

    Anyways I just ordered a pair off of Amazon. They were cheaper than OLMs and you can't argue with almost 300 reviews and 4.5/5 stars!
    ...BECAUSE RALLY CAR

    Current Build: 2015 WRX Premium - WRB - Stage 2

  8. #7
    Registered User GT800's Avatar
    Join Date
    Jan 2014
    Posts
    276
    I have the sylvanias in my c lights and they make all my others look like crap. To expensive though

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •