2012 wrx will hardly idle after I changed my plugs
+ Reply to Thread
Results 1 to 4 of 4

This is a discussion on 2012 wrx will hardly idle after I changed my plugs within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Hey what's up everyone? I had an issue with my wrx it was reading cylinder 3 misfire and I thought ...

  1. #1
    Registered User $poolnWRX's Avatar
    Join Date
    Mar 2017
    Posts
    24

    2012 wrx will hardly idle after I changed my plugs

    Hey what's up everyone? I had an issue with my wrx it was reading cylinder 3 misfire and I thought I fouled a plug or burned up a coil pack but that was not the case. The plug came lose on cylinder 3 that's all I already had the car apart to do the plugs so I changed those as well with the same exact plugs that were already in it. One thing is the battery was out of the car for 4 days. Would I need to reinstall the e85 map since there was no battery, I had to set the clock again and the radio so I was hoping this might be the problem. When I am driving the car it runs fine just when I come to a stop it dies and if I start it and sit there it will try hard to idle and after a few seconds it will stay idleing but tent to hard to just idle

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Mar 2016
    Posts
    68
    Did you gap and torque the plug down? Is the coilpack connected correctly? And last of all, check all of your vacuum lines

  4. #3
    lit fam XJman's Avatar
    Join Date
    Feb 2015
    Location
    At work
    Posts
    5,892
    I think you have a bigger issue somewhere

    Sent from my SAMSUNG-SM-G935A using Tapatalk
    All? NO ALL!

  5. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  6. #4
    Registered User $poolnWRX's Avatar
    Join Date
    Mar 2017
    Posts
    24
    Well there was no bigger issues here, since my battery was out I had to reset the ECU and the car just had to relearn problem solved. Best to check all the small things first. Happy there is no real problems she runs great on e-85

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •