2015 sti quit @ 55mph
+ Reply to Thread
Page 1 of 2 12 LastLast
Results 1 to 15 of 26

This is a discussion on 2015 sti quit @ 55mph within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Well here I am excited as anyone can be about obtaining brand spanking new 2015 sti and had a near ...

  1. #1
    Registered User
    Join Date
    Oct 2014
    Posts
    5

    2015 sti quit @ 55mph

    Well here I am excited as anyone can be about obtaining brand spanking new 2015 sti and had a near perfect 4000 miles with the exception of the nav/bluetooth all of the sudden not pairing with anything. So they tried to look at and fix but ordered a new head unit instead. While waiting the week or so for it to arrive with the SUBIE I was headed out of town on a two laner @ 55 mph and hit a tiny (normal) bump and alas all of the sudden all of the electrical led indicators started blinking and come to find out the car engine stopped midflight. I was able to steer it to the side safely but I am glad I wasn't in LA or somewhere where I would have been hit! The engine would not ever start again. push button and blinky blinky with everything and nothing. So towed next morn to Dealership of origin. Still there 11 days later......no clue other than ignition fuse pops every time they try. So they say they will hunt down a shorted wire near firewall etc etc (they do not really know). That was a week and a half ago. This is a BRAND NEW 2015 metallic grey STI off the showroom floor with favorable additions like the nav system, harmon cardon etc. . I have done nothing with it. What to do. I have waited most of my adult life for a car of this caliber and ......? I didn't take the 100,000 mile or the maintenance but maybe I should have or maybe after they have taken my brand new car apart at its seams I can get it back all duct taped up and what not. Not too Happy and needed to vent. Thanks for listening. Any recommends let me know... ( oh but they put me in an enterprise corolla while i wait)

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    2,277
    Corollas are nice

    Haven't heard of this issue. Does sound like a short somehwere...especially if it's popping every time they try. Don't worry much though. I know it's a new car but trust the dealer to fix it..and they will properly
    Stinkeye member 520

  4. #3
    Registered User
    Join Date
    Jan 2014
    Location
    East Coast
    Posts
    95
    While frustrating, this could happen to any car, you will enjoy it once you get it back.
    Chris
    '14 WRX Crystal Black/SPT CBE/Tuned by Torqued Performance

  5. #4
    Registered User
    Join Date
    May 2014
    Location
    Sonoma coast, CA
    Posts
    86
    Boooooo! Just boo. Let us know when back in the saddle.

  6. #5
    Banned
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,644
    I Support ClubWRX
    4000 miles and the dealer took it in on warranty? Sounds like much complaining about nothing....

  7. #6
    Registered User WrxNate's Avatar
    Join Date
    Aug 2013
    Location
    Milwaukee,WI
    Posts
    212
    Quote Originally Posted by Drews View Post
    4000 miles and the dealer took it in on warranty? Sounds like much complaining about nothing....
    Kinda agree with Drews here. Random things happen..... randomly. I have no doubt that the dealership will find the issue and repair it like new. It's not like they expected this to happen, and they probably haven't seen this issue before. As much as it sucks, be patient and you'll have your car back soon. I also seriously hope you don't think a dealership would actually "duct tape" it back together.
    Nate | Stink Eye Mob #023

    2014 WRB WRX Hatch

  8. #7
    Registered User
    Join Date
    Oct 2014
    Posts
    5
    Quote Originally Posted by WrxNate View Post
    Kinda agree with Drews here. Random things happen..... randomly. I have no doubt that the dealership will find the issue and repair it like new. It's not like they expected this to happen, and they probably haven't seen this issue before. As much as it sucks, be patient and you'll have your car back soon. I also seriously hope you don't think a dealership would actually "duct tape" it back together.
    well it appears that it was sent from the factory with the wiring harness to tight and several wires were severed including ignition. Fixed now but I do not care to be a 40,000 Dollar beta tester for Subaru.

  9. #8
    Registered User Goose42's Avatar
    Join Date
    Jun 2014
    Location
    Portland, Oregon
    Posts
    498
    Glad to hear it is fixed Bob, have any photos? Love the DGM.
    Drive like hell, you will get there faster!

    2015 CWP WRX Premium
    Warranty friendly mods for now-

    http://www.clubwrx.net/forums/builds...ml#post3579257

  10. #9
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,337
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by bobsti2015 View Post
    well it appears that it was sent from the factory with the wiring harness to tight and several wires were severed including ignition. Fixed now but I do not care to be a 40,000 Dollar beta tester for Subaru.
    Sorry to say, but you bought the wrong car.
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  11. #10
    Registered User
    Join Date
    May 2014
    Location
    Sonoma coast, CA
    Posts
    86
    Haha, if you want to know what being a beta tester is, you shoulda got one of the lil 2.0 DIT contraptions! Talk about the 'excitement package'...ala NPRs Click and Clack.

  12. #11
    Registered User
    Join Date
    Oct 2014
    Posts
    5
    Happily back together again. Click image for larger version. 

Name:	IMG-20140817-00990.jpg 
Views:	94 
Size:	115.0 KB 
ID:	170914Click image for larger version. 

Name:	IMG-20140817-00992.jpg 
Views:	93 
Size:	113.7 KB 
ID:	170922

  13. #12
    Registered User snakerb's Avatar
    Join Date
    Sep 2014
    Posts
    26
    Glad to see/hear you're reunited again.

  14. #13
    Administrator TheJ's Avatar
    Join Date
    Jul 2002
    Location
    Bro do you even live in the Dirty South
    Posts
    18,066
    I Support ClubWRX
    Welcome to Club.


    The misfortune sucks and I know that it is frustrating dealing with towing and waiting etc with a new car. Especially one you were probably very happy to finally get.



    Good that it's fixed though!



    It sure looks great too
    -The J
    New Members, CLICK & BOOKMARK these links:


    "Driving most supercars is like trying to manhandle a cow up a back staircase. . . This is like smearing honey into Keira Knightly" -JC

  15. #14
    Banned
    Join Date
    Aug 2008
    Location
    Davey Jones Locker
    Posts
    8,644
    I Support ClubWRX
    Quote Originally Posted by bobsti2015 View Post
    well it appears that it was sent from the factory with the wiring harness to tight and several wires were severed including ignition. Fixed now but I do not care to be a 40,000 Dollar beta tester for Subaru.
    Because that's exactly what you are. Subaru is intentionally placing "defects" into their cars to see if the consumers catch them.

  16. #15
    Registered User WrxNate's Avatar
    Join Date
    Aug 2013
    Location
    Milwaukee,WI
    Posts
    212
    Quote Originally Posted by bobsti2015 View Post
    Fixed now but I do not care to be a 40,000 Dollar beta tester for Subaru.
    I understand the feeling, but you should have very well expected their to be minor issues when buying the first year of a revamp.
    Nate | Stink Eye Mob #023

    2014 WRB WRX Hatch

+ Reply to Thread
Page 1 of 2 12 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •