Drain plug issue please help !
+ Reply to Thread
Results 1 to 5 of 5

This is a discussion on Drain plug issue please help ! within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; i have a 2005 STI and im doing the first oil change since i got it. i removed everything and ...

  1. #1
    Registered User
    Join Date
    May 2014
    Location
    Westchester,NY
    Posts
    6

    Drain plug issue please help !

    i have a 2005 STI and im doing the first oil change since i got it. i removed everything and went to remove the drain plug but its something ive never seen before. i have no idea how to remove it, anybody else have this kind of drain plug ? the wires that are coming out of it for temp and low level i think.

    Heres what it looks like ....


  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    He simply abides. SD_GR's Avatar
    Join Date
    Jul 2002
    Location
    CA, US
    Posts
    22,973
    I Support ClubWRX
    Isn't there a second bolt facing down and back?
    WRX Info Links, Courtesy TheJ
    Man is a brute.... If you're cruel to him, he respects and fears you. If you're kind to him, he plucks your eyes out. Alexis Zorbas
    I lied. I cheated. I bribed men to cover the crimes of other men. I am an accessory to murder. But the most damning thing of all... I think I can live with it. And if I had to do it all over again - I would. Benjamin Sisko
    DISCLAIMER: Opinions expressed are the author's alone and are inherently worthless.

  4. #3
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    2,602
    Looks like some time ago someone stripped out the oil pan and that's am oversized drain plug. Usually I keep the bigger bolt in at work and take off the smaller one as I don't want to wear out the already damaged threads of the pan
    Stinkeye member 520

  5. #4
    Registered User DiRty Impreza's Avatar
    Join Date
    Jun 2011
    Location
    Canton, Ohio
    Posts
    211
    No its just the sensor for the gauge, you must have Lamco gauges? I had the same thing on my 02. They make a socket with a slot for the wire. Or if i remember correctly, a 19" wrench will do.
    ++ + ++P3LLA++ + ++

    06 STi ( Stage II ) BOOSTED
    HAWK-EYE ALLIANCE # 808

  6. #5
    Registered User nsibanez's Avatar
    Join Date
    Aug 2012
    Location
    Tucson, AZ
    Posts
    2,602
    Oooooh, now I see it. Kinda hard to tell
    Stinkeye member 520

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •