Just got my first Subaru, need help !
Results 1 to 2 of 2

This is a discussion on Just got my first Subaru, need help ! within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; I just drove home my first Subaru, 2005 STI and the 2 hour drive i noticed the temperature gauge kept ...

  1. #1
    Registered User
    Join Date
    May 2014
    Location
    Westchester,NY
    Posts
    5

    Just got my first Subaru, need help !

    I just drove home my first Subaru, 2005 STI and the 2 hour drive i noticed the temperature gauge kept going from normal to high and back again after a few seconds for most of the ride home mostly when i was off the throttle. Do you thinks its just air in my system or bad thermostat?..... and also when i got home in my driveway i noticed coolant spilled all over underneath it looks like a small puddle under the resivour not sure if leaking or the pervious owner filled it up before selling it to me and spilled some.Any suggestions ?!

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Raven Logics's Avatar
    Join Date
    Dec 2007
    Location
    Canada
    Posts
    720
    Quote Originally Posted by xRYANx23 View Post
    I just drove home my first Subaru, 2005 STI and the 2 hour drive i noticed the temperature gauge kept going from normal to high and back again after a few seconds for most of the ride home mostly when i was off the throttle. Do you thinks its just air in my system or bad thermostat?..... and also when i got home in my driveway i noticed coolant spilled all over underneath it looks like a small puddle under the resivour not sure if leaking or the pervious owner filled it up before selling it to me and spilled some.Any suggestions ?!
    Maybe a leak causing air to enter the system? Is the level constant or dropping?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •