Replaced radiator still heating up.....IM LOOSING MY MIND!
Results 1 to 6 of 6

This is a discussion on Replaced radiator still heating up.....IM LOOSING MY MIND! within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Just replaced my radiator on my 04 wrx. It's still heating up and can't figure out why. Fans are working, ...

  1. #1
    Registered User
    Join Date
    Feb 2013
    Location
    PA
    Posts
    9

    Replaced radiator still heating up.....IM LOOSING MY MIND!

    Just replaced my radiator on my 04 wrx. It's still heating up and can't figure out why. Fans are working, put enough coolant in, and checked the pressure. Need some help

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Obeisance's Avatar
    Join Date
    Apr 2012
    Location
    Ann Arbor
    Posts
    250
    Can you confirm that the system is well burped?

    Is there anything blocking airflow through the radiator (perhaps something in between the A/C condenser and radiator)?

    Have you checked on the state of the water pump and thermostat (are they still working properly)?

    Do you know if the water temperature gauge in the cabin is correct? (i.e. is there a gauge or thermometer problem)
    David - '05 WRX

  4. #3
    Registered User
    Join Date
    Feb 2013
    Location
    PA
    Posts
    9
    im going to try burping it again in an hour i just did it 10 mins ago had it on a hill, waited till the bubbles stopped and turned it off. I drove it up the hill and back and still heating up

  5. #4
    Registered User Ingo's Avatar
    Join Date
    Mar 2012
    Location
    Colorado Springs, CO
    Posts
    1,110
    Quote Originally Posted by Obeisance View Post
    Can you confirm that the system is well burped?

    Is there anything blocking airflow through the radiator (perhaps something in between the A/C condenser and radiator)?

    Have you checked on the state of the water pump and thermostat (are they still working properly)?

    Do you know if the water temperature gauge in the cabin is correct? (i.e. is there a gauge or thermometer problem
    )
    You can't have everything - where would you put it?

  6. #5
    Registered User CLMan's Avatar
    Join Date
    Feb 2014
    Posts
    3
    Hey man same thing happened to me when I picked up my 04 wrx it happened when the storm hit us, at first I topped off the cooliant to make it wasn't leaking and it was, it turned out that the CORE RADIATOR HOSE split, check your fluids


    Sent from my iPhone using Tapatalk
    Using Tapatalk

  7. #6
    Registered User
    Join Date
    Feb 2013
    Location
    PA
    Posts
    9

    Fixed

    It wasn't well burped and this was my first time changing my radiator, i do appreciate everyones replies!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •