Got Iphone4 replacement doesnt seem to be pairing correctly with bluetooth now
Page 1 of 2 12 LastLast
Results 1 to 15 of 24

This is a discussion on Got Iphone4 replacement doesnt seem to be pairing correctly with bluetooth now within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Before my phone would automatically sync up when i got into the car My music would start playing, or my ...

  1. #1
    Registered User YorkWRX11's Avatar
    Join Date
    Mar 2011
    Location
    SoCAL
    Posts
    161

    Got Iphone4 replacement doesnt seem to be pairing correctly with bluetooth now

    Before my phone would automatically sync up when i got into the car My music would start playing, or my call I was on would auto transfer to my bluetooth in around 15 seconds. Not it is not connecting at all or taking about 2 minutes to pair. Am i not doing something right? My last phone was done by the dealer but I would prefer not to go into them if possible.

    I went through the syncing and put the password in. Screen reads paired.
    Not sure if I'm missing anything.

    Thanks for any help
    11 SWP LMTD Hatch SPT Exhaust, Kartboy STS w/ Bushings, 30% Tint, Red tails, Stage 1 TP Tune

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Aug 2011
    Location
    Dobbs Ferry, NY
    Posts
    226
    Well you can re-try the whole thing? Delete all the phones stored on there currently, and try to repair your phone.
    Just a thought?

    I believe the pairing key is 0000?

  4. #3
    Registered User
    Join Date
    Aug 2011
    Location
    Alberta, Canada
    Posts
    60

    same problem

    yup i have the exact same problem. unfortuately i havent been able to fix it. i set it up myself the first time, got a replacement and since then i havent been able to get it to work automatically. i was thinking of going to an apple store and asking them. i havent contacted the dealership yet either. prob going to this weekend

  5. #4
    Registered User TrozPSU's Avatar
    Join Date
    Jul 2009
    Location
    Pittsburgh, PA
    Posts
    102
    Did you update to iOS5 yet? I just did it yesterday and noticed that it now streams track information (and some other things like repeat and random settings). Maybe the new software will kick it back to normal.

  6. #5
    Registered User YorkWRX11's Avatar
    Join Date
    Mar 2011
    Location
    SoCAL
    Posts
    161
    So this worked for me.

    First I renamed my phone in iTunes by adding II to the end of name.

    Next I used the handsfree method to list what phones were in system. Even though I thought it had deleted them all using the headunit way... it didn't. It listed it again so I completely deleted all of the phones.

    After clearing all names through handsfree way( on steering wheel) I finally re-paired it using the voice commands.

    Everything seems to be working like normal again hope this helps
    11 SWP LMTD Hatch SPT Exhaust, Kartboy STS w/ Bushings, 30% Tint, Red tails, Stage 1 TP Tune

  7. #6
    Registered User rgold01's Avatar
    Join Date
    Apr 2004
    Location
    Westminster, CO
    Posts
    189
    i had no problems after updating to ios5 with iPhone 4
    97 Ninja 600r sold
    99 integra gsr sold
    02 pathfinder sold
    01 YamFZR 600 sold
    04 WRX Sold
    2011 WRX DGM
    Good judgement is based upon experience. Experience is based upon BAD JUDGEMENT!!!

  8. #7
    Registered User rudyrex's Avatar
    Join Date
    Feb 2011
    Posts
    30
    Had the same issue. Deleted the phone from the bluetooth (go through setup to kill). Make sure you name the new phone something different. Had issues until a changed the name on the new phone. Works great now. IOS5 also works great.

    Good luck

  9. #8
    Registered User Turb0Licious's Avatar
    Join Date
    Oct 2011
    Location
    NJ/PA
    Posts
    59
    My phone (Droid) doesn't connect when I get into my WRX, It says it's paired but I have to go into Bluetooth in my phone and manually connect it, even when my BT in on, etc. I've read up on this, can't seem to get it going, any thoughts?

    Also, don't like that just the number comes up across the head unit not the callers name as in my phone book? Would this be a sync issue?

  10. #9
    Registered User phatmack's Avatar
    Join Date
    Sep 2011
    Location
    Denver
    Posts
    28
    Quote Originally Posted by Turb0Licious View Post
    My phone (Droid) doesn't connect when I get into my WRX, It says it's paired but I have to go into Bluetooth in my phone and manually connect it, even when my BT in on, etc. I've read up on this, can't seem to get it going, any thoughts?

    Also, don't like that just the number comes up across the head unit not the callers name as in my phone book? Would this be a sync issue?
    This is the way mine is as well... though I didn't assume anything was wrong. Maybe iPhone users can correct me but I believe the Bluetooth tech in the car doesn't sync your phone book... it just spits out the number of the incoming/outgoing call.

    Not sure what to do about it pairing right up though. I've not had this issue (EVO 4G) with mine... always seems to pair up after a couple of seconds. You've re-paired it I assume?

  11. #10
    Registered User tommy_c's Avatar
    Join Date
    Jun 2011
    Location
    Philadelphia, PA
    Posts
    477
    Same problem when I went from my BB to the new iPhone 4s. Just re-connected the phone to the car as if the car was never hooked up to a phone previously. I even changed the passcode once just to be safe but I doubt you would have to do that step to make the bluetooth connect. Everything seems to work fine now.

    Quote Originally Posted by Turb0Licious View Post
    Also, don't like that just the number comes up across the head unit not the callers name as in my phone book? Would this be a sync issue?
    From what I understand you need to manually plug names into the car for it to work. Theres no sync option for the car with your contacts...

  12. #11
    Registered User brew04's Avatar
    Join Date
    Sep 2011
    Location
    Seattle, WA
    Posts
    99
    The BT system isn't that top of the line. More of a fancy headset than a computer linking to your phone and accessing all the data. When connected correctly it will see incoming calls but it doesn't know what the phone knows about that number.

    I connected my Samsung Charge pretty easily. Only problem I had was that it would connect as a phone and a music player, starting up the music I had on my phone and playing it through the phone speaker since I wasn't using the BT connection on the Head unit. When connected to the car though I was able to select for the connection to be either for phone or for music player.

  13. #12
    Lando Calrissian DemonWRX's Avatar
    Join Date
    Jul 2011
    Location
    Cloud City, Bespin
    Posts
    3,266
    I Support ClubWRX
    ok.... since this thread has info for both Droids and iPhones, I will post here...

    2011 WRX with navi....Droid3. Mine connects the phone to the car without issue automatically, but I can't get it to send music.... anyone have some tips for me?
    Stink-Eye Mob #39
    N.E.R.D. Operative #8

  14. #13
    Lando Calrissian DemonWRX's Avatar
    Join Date
    Jul 2011
    Location
    Cloud City, Bespin
    Posts
    3,266
    I Support ClubWRX
    Quote Originally Posted by Turb0Licious View Post
    My phone (Droid) doesn't connect when I get into my WRX, It says it's paired but I have to go into Bluetooth in my phone and manually connect it, even when my BT in on, etc. I've read up on this, can't seem to get it going, any thoughts?

    Also, don't like that just the number comes up across the head unit not the callers name as in my phone book? Would this be a sync issue?
    From what I have read, no way to sync the phone book.... you have to add it manually. As for connecting, make sure you have your phone set to auto connect, and the car unit set to auto connect. Both have this setting somewhere. My Droid3 and head unit connect automatically without issue (for the phone atleast, still working on the BT music streaming)
    Stink-Eye Mob #39
    N.E.R.D. Operative #8

  15. #14
    Registered User Turb0Licious's Avatar
    Join Date
    Oct 2011
    Location
    NJ/PA
    Posts
    59
    Quote Originally Posted by DemonWRX View Post
    From what I have read, no way to sync the phone book.... you have to add it manually. As for connecting, make sure you have your phone set to auto connect, and the car unit set to auto connect. Both have this setting somewhere. My Droid3 and head unit connect automatically without issue (for the phone atleast, still working on the BT music streaming)
    I haven't messed around with it too much, but I have unpaired and reconnected it (like it was never connected before) but still not connecting automatically, ill tweak it later when I toss in my new 9005s. For your music, is your phone connected to "phone and media" or just phone, make sure it's both, sometimes It just connects the phone, without the music. I'm sure you'll figure it out.

  16. #15
    Lando Calrissian DemonWRX's Avatar
    Join Date
    Jul 2011
    Location
    Cloud City, Bespin
    Posts
    3,266
    I Support ClubWRX
    Quote Originally Posted by tommy_c View Post
    From what I understand you need to manually plug names into the car for it to work. Theres no sync option for the car with your contacts...


    THIS IS POSSIBLE!!!!!!

    So I started playing with the BT features today after work....I got my Droid 3 to sync the contact list to my navi. Not sure if this is the only way, but it is what I used, and it worked!

    First, I installed an app called Bluetooth file transfer (free app). I added it as a widget to the home screen. This will allow you to enable BT as well as BT-FTP (send files) and BT-OPP (to have other devices send commands to your phone). Widget looks like this, enable the three I circled:

    Then on the car, follow the green circles on your navi starting from the menu




    at this point, back on your phone. pull up your contacts

    press your menu button and select to share name cards

    at this point you select which contact to share (done with check marks). after finishing your selections press done and you will be asked how you want to share

    then what device to share with

    After your transfer is complete, the navi will have your contacts



    Now I just need to get the audio streaming working.

    I would assume there is a way to do this with an iPhone, but I never drank Steve's Cool-aid
    Stink-Eye Mob #39
    N.E.R.D. Operative #8

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •