09 WRX Engine Failures
Page 1 of 24 1234567891011 ... LastLast
Results 1 to 15 of 349

This is a discussion on 09 WRX Engine Failures within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Just a heads up to 09 WRX owners. Possible rash of Engine failures similar to the 08 STi 2009 Impreza ...

  1. #1
    Registered User
    Join Date
    May 2007
    Posts
    4

    09 WRX Engine Failures

    Just a heads up to 09 WRX owners. Possible rash of Engine failures similar to the 08 STi

    2009 Impreza WRX motor issues - Page 7 - NASIOC

    Josh

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User andyinwi's Avatar
    Join Date
    Oct 2008
    Location
    Wisconsin
    Posts
    18

    Do we need to start a ClubWRX thread on this issue?

    Makes my stomch hurt. I went though this undesirable VIN number thing once before with another car. My 09 only has like 600 miles on it. I wonder if there's a preventative measure that could be done at the dealer?

    Anyone have the VIN number window mapped out yet?

  4. #3
    Registered User Mr. Poon's Avatar
    Join Date
    Jul 2004
    Location
    Ellsworth, ME
    Posts
    157
    Quote Originally Posted by Whiteghost2.5 View Post
    Just a heads up to 09 WRX owners. Possible rash of Engine failures similar to the 08 STi

    2009 Impreza WRX motor issues - Page 7 - NASIOC

    Josh
    I test drove one of the first 09 WRX 5 doors in my area, drove it up the interstate one exit and back and never exceeded 3K rpms and never gave it more than half throttle. Someone bought it a couple days later and blew the engine the NEXT DAY. Dealer had to replace the engine. Pretty incredible.
    2009 WRX 5Door- Silver
    2008 Toyota Tundra SR5 Crewmax
    1957 Willy's CJ3B, '73 Corvette Yellow

  5. #4
    Registered User Spincycle's Avatar
    Join Date
    Jul 2007
    Location
    Janesville, WI
    Posts
    328
    I don't think there is enough data yet to really for sure say this is going to be a problem for a lot of 09 WRX owners, but it's not looking good with about 10 09 WRX's having problems on NASIOC.

  6. #5
    Registered User
    Join Date
    Jan 2005
    Location
    Maine
    Posts
    6
    09 WRX sedan here. Just bought it a couple weeks ago. 900 miles no problems, knock on wood, though it does make me nervous...

  7. #6
    Registered User
    Join Date
    Nov 2008
    Posts
    47
    Quote Originally Posted by Carter View Post
    09 WRX sedan here. Just bought it a couple weeks ago. 900 miles no problems, knock on wood, though it does make me nervous...
    im at almost 3k here, no problems thus far

  8. #7
    Registered User NjBuGeyEdWRX's Avatar
    Join Date
    Apr 2007
    Location
    Beachwood NJ
    Posts
    1,340
    there is a video on youtube of either an 08 or 09 wrx with i think 1000 miles on it that spun a bearing already.
    03 WRB WRX STAGE II
    STi COMING SOON

    BUGEYE MAFIA #199

    LET ME QUOTE THE LATE COLONEL SANDERS " I'M TO DRUNK TO TASTE THIS CHICKEN . . ."

  9. #8
    Registered User elwray's Avatar
    Join Date
    Nov 2008
    Location
    Central NJ
    Posts
    994
    09 WRX hatch... about 2k so far. No problems - knock on wood - sometimes the revs hang up when putting the clutch in in stop and go traffic I dont know, the engine is still breaking in (not just breaking, I hope )

    Either way, obviously it's a concern and I will keep watching these 09 problem threads..
    Last edited by elwray; 06-23-2009 at 12:34 PM.

  10. #9
    Registered User NjBuGeyEdWRX's Avatar
    Join Date
    Apr 2007
    Location
    Beachwood NJ
    Posts
    1,340
    Quote Originally Posted by elwray View Post
    I for one did NOT follow the manual's break-in procedures, and routinely "drive it like I stole it" , since day 1 from the dealership.
    smart move . . .
    03 WRB WRX STAGE II
    STi COMING SOON

    BUGEYE MAFIA #199

    LET ME QUOTE THE LATE COLONEL SANDERS " I'M TO DRUNK TO TASTE THIS CHICKEN . . ."

  11. #10
    Registered User
    Join Date
    Jan 2005
    Location
    Maine
    Posts
    6
    well babying them does't seem to help...

  12. #11
    Registered User
    Join Date
    Apr 2007
    Location
    Jackson WY
    Posts
    5
    [QUOTE=elwray;2405349]09 WRX hatch... about 2k so far. No problems - knock on wood - sometimes the revs hang up when putting the clutch in in stop and go traffic I dont know, the engine is still breaking in (not just breaking, I hope )

    I for one did NOT follow the manual's break-in procedures, and routinely "drive it like I stole it" , since day 1 from the dealership.



    I just got an 09 wrx, 1500mls no engine troubles yet, but i too get the revs hanging up in stop and go and reverse. maybe my footwork maybe not. any input?
    Last edited by 04SILXT; 01-05-2009 at 04:28 PM.

  13. #12
    Registered User
    Join Date
    Nov 2008
    Posts
    16
    i have my 09 over 3K miles and have no issue still running good

  14. #13
    Registered User ScoobyNuby's Avatar
    Join Date
    Apr 2008
    Location
    Newberg, Or
    Posts
    292
    my 08 does that hang up thing every once in awhile also. 12k, no problems, and I too have driven it like I stole it from 200 miles on.
    -Stink-Eye Mob #51-
    08' SEDAN
    SPT CAT BACK

  15. #14
    Registered User elwray's Avatar
    Join Date
    Nov 2008
    Location
    Central NJ
    Posts
    994
    Yeah, seems to be a "normal" thing. I wouldn't worry about it. Just think of it as holding your revs to help you launch

  16. #15
    Registered User
    Join Date
    Dec 2008
    Posts
    1
    I just had it happen yesterday, its at the dealer now waiting for the official verdict. It really makes me sad. Other than this i love my 09. Btw i had 26xx on it and did a proper break in.

Page 1 of 24 1234567891011 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •