09 WRX Engine Failures - Page 3
Page 3 of 24 FirstFirst 12345678910111213 ... LastLast
Results 31 to 45 of 349

This is a discussion on 09 WRX Engine Failures within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Ok, you win. It's important because there is a whole one-third of a page they put into it compared to ...

  1. #31
    Registered User tuskenraider's Avatar
    Join Date
    Aug 2004
    Location
    Chicago area
    Posts
    187
    Ok, you win. It's important because there is a whole one-third of a page they put into it compared to how you should adjust your seat, change your wipers, etc., which is pages.........do as you will.
    Last edited by tuskenraider; 03-29-2009 at 04:40 PM.
    '11 WRX Hatch
    Lightning Red

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #32
    Registered User Scubie33's Avatar
    Join Date
    Feb 2009
    Location
    Norman, OK
    Posts
    9
    Man I hope my car doesn't blow up.
    First they ignore you.
    Then they laugh at you.
    Then they fight you.
    Then you win.

    Mahatma Gandhi

  4. #33
    Registered User Liquidr1's Avatar
    Join Date
    Oct 2008
    Location
    Greensboro, NC
    Posts
    320
    has subaru gotten this issue fixed yet.
    2009 Impreza WRX Hatch.
    Cobb AccessPort: Cobb Protune @ Draco Performance
    346 ft/lbs 289 awhp.
    Perrin CAI.
    Perrin Performance Catback.
    Perrin Performance 3" catted downpipe
    SPT boost guage.

  5. #34
    Registered User Liquidr1's Avatar
    Join Date
    Oct 2008
    Location
    Greensboro, NC
    Posts
    320
    has subaru gotten this issue fixed yet.
    2009 Impreza WRX Hatch.
    Cobb AccessPort: Cobb Protune @ Draco Performance
    346 ft/lbs 289 awhp.
    Perrin CAI.
    Perrin Performance Catback.
    Perrin Performance 3" catted downpipe
    SPT boost guage.

  6. #35
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,340
    I Support ClubWRX
    we/re assuming so as there have been no failures reported on any Oct or later build dates- many of these cars already have significant mileage on them

    I'd insure if I were to purchase a July-Sept build that it already has the new engine in it
    "Simplify and add lightness." - Colin Chapman

  7. #36
    Registered User ergabe's Avatar
    Join Date
    Feb 2009
    Posts
    31
    Quote Originally Posted by elwray View Post
    I for one did NOT follow the manual's break-in procedures, and routinely "drive it like I stole it" , since day 1 from the dealership.
    +1
    the build date on my wrx 09 is 07/08. had 7000 + miles on it already untill now still kicking!
    cant even remember how many times i over rev the engine so bad.

  8. #37
    Registered User Liquidr1's Avatar
    Join Date
    Oct 2008
    Location
    Greensboro, NC
    Posts
    320
    well i was going to get an 09 wrx but i held off because of this issue.

    i will definitly not purchase one until i know this issue has been resolved. perhaps ill just wait till the 2010 models are being produced.
    2009 Impreza WRX Hatch.
    Cobb AccessPort: Cobb Protune @ Draco Performance
    346 ft/lbs 289 awhp.
    Perrin CAI.
    Perrin Performance Catback.
    Perrin Performance 3" catted downpipe
    SPT boost guage.

  9. #38
    Registered User mwake1's Avatar
    Join Date
    Dec 2008
    Location
    SLC, UT
    Posts
    57

    Mine just went

    Bought the 09 WRX last november. It's our daily commuter and road trip car, now has about 14,000 miles.
    Yesterday, started noticing an odd rattling sound, like a loose metal or plastic piece, and maybe a kind of ticking sound when idling. Then coming home last night, the rattling was getting worse, I get off the freeway with a long gradual downhill street, so I throw it into neutral to just coast and the engine dies. It starts back up but now it sounds like the engine is eating itself, fortunately I was pretty much at my house already. I don't think I can even drive it to the dealer, I'll have to tow.
    I'll go check the build date, inside driver door?

  10. #39
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,340
    I Support ClubWRX
    also if go to youtube there are several good examles of the noise you'll hear w/ a spun bearing- my guess is w/ a Nov purchase you have a 07/08 build
    "Simplify and add lightness." - Colin Chapman

  11. #40
    Registered User 2w0r0x9's Avatar
    Join Date
    May 2009
    Location
    LBI, NJ
    Posts
    431
    i hate when this thread gets bumped up..im still praying i survive this crappy problem

  12. #41
    Registered User mwake1's Avatar
    Join Date
    Dec 2008
    Location
    SLC, UT
    Posts
    57
    I know what you mean, at 14,000 I thought I was in the clear.

  13. #42
    Registered User mwake1's Avatar
    Join Date
    Dec 2008
    Location
    SLC, UT
    Posts
    57
    I just checked, it's the 08/08 build. Tow truck is coming now to take it to the dealer

  14. #43
    Registered User ILikeToGoFast's Avatar
    Join Date
    Dec 2008
    Location
    Calgary
    Posts
    42
    That's hurting, dude. Sorry to hear it. I know the feeling. Hopefully the mechanics are good, I had some issues that were apparently due to a mistake when reinstalling the engine. They installed a new ECU, changed some air valves, and reinstalled some gaskets.

    -IL2GF

  15. #44
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,340
    I Support ClubWRX
    Quote Originally Posted by mwake1 View Post
    I just checked, it's the 08/08 build. Tow truck is coming now to take it to the dealer
    if you haven't already would you mind posting in the thread at nasioc.com- we'e documented over 70 cases thus far
    "Simplify and add lightness." - Colin Chapman

  16. #45
    Registered User
    Join Date
    May 2006
    Location
    Portsmouth, NH
    Posts
    69
    Quote Originally Posted by Big Sky WRX View Post
    we/re assuming so as there have been no failures reported on any Oct or later build dates- many of these cars already have significant mileage on them

    I'd insure if I were to purchase a July-Sept build that it already has the new engine in it
    I'm keeping my fingers crossed with what I'm thinking is a late oct build with a VIN#810*** I've seen a few oct builds with 809's?? Still haven't heard of any oct build failures. got 6500 on the odo.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •