09 WRX Engine Failures - Page 19
+ Reply to Thread
Page 19 of 24 FirstFirst ... 9101112131415161718192021222324 LastLast
Results 271 to 285 of 349

This is a discussion on 09 WRX Engine Failures within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Hey, Im looking to buy an '09 that falls within the vin range. Its got 33K on the odometer. Should ...

  1. #271
    Registered User
    Join Date
    Mar 2011
    Posts
    1
    Hey, Im looking to buy an '09 that falls within the vin range. Its got 33K on the odometer. Should I try to find somthing that doesnt fall in the range, or is this somthing thats not a big deal. I know that they've been good about replacing engines, has anyone had a replaced engine that failed?

    thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #272
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,365
    I Support ClubWRX
    find out if the engine has already been replaced, if so your good to go

    if it hasn't (or they don't know)- I'd walk away, you never know when (or even if) it will go and not being the original owner and having all the oil change receipts you might have trouble w/ warranty

    my .02
    "Simplify and add lightness." - Colin Chapman

  4. #273
    Registered User jesterking's Avatar
    Join Date
    Feb 2011
    Location
    NY, no not the city.
    Posts
    38
    From what I've read if your up to 33k on the original engine, chances are that car won't have the issue. It was a very limited run of engines that had the problem. I don't think the vin's really shed any light to what engines would fail. Least I couldn't find a correlation. Remember, people who post things of that nature on the Internet are the ones who have a problem... You never see a counter posts of the thousands of people who don't have problems. Worst case, you buy it, and if it happens bring it back to the dealer and have them repair it. I would ask that question though while at the dealership.

  5. #274
    Registered User SkoobieDoo's Avatar
    Join Date
    Feb 2011
    Posts
    68
    [QUOTE=04SILXT;2409456]
    Quote Originally Posted by elwray View Post
    09 WRX hatch... about 2k so far. No problems - knock on wood - sometimes the revs hang up when putting the clutch in in stop and go traffic I dont know, the engine is still breaking in (not just breaking, I hope )

    I for one did NOT follow the manual's break-in procedures, and routinely "drive it like I stole it" , since day 1 from the dealership.



    I just got an 09 wrx, 1500mls no engine troubles yet, but i too get the revs hanging up in stop and go and reverse. maybe my footwork maybe not. any input?
    thats how my dad told me how to do it drive it hard if any problems happen with in the first 1000 miles..

  6. #275
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    Quote Originally Posted by WRX2k9 View Post
    I bought one with 15k. No issues. I have rev hang-up as well but I believe it's due to my timing during shifts. If I concentrate it's fine.
    Rev hang is a fault of the ECU programing Its actually designed to do that. Why? dont ask me, but its annoying as hell. I've driven more than a few other newer manual trans cars that did it too. Mine also does it (2010 hatch 43K mi) .. especially if rolling through a parking lot in 1st.. let off the gas to slow down n clutch.. the revs hang around 2k till you pull it out of gear.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  7. #276
    Registered User jesterking's Avatar
    Join Date
    Feb 2011
    Location
    NY, no not the city.
    Posts
    38
    Quote Originally Posted by mangostick View Post
    Rev hang is a fault of the ECU programing Its actually designed to do that. Why? dont ask me, but its annoying as hell. I've driven more than a few other newer manual trans cars that did it too. Mine also does it (2010 hatch 43K mi) .. especially if rolling through a parking lot in 1st.. let off the gas to slow down n clutch.. the revs hang around 2k till you pull it out of gear.
    I always thought rev hang was to help with transitioning of the gears. No heal toe needed.

  8. #277
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    actually going from 1st at high rpm into 2nd it will hurt you.. or .. well hurt the ability to quickly get into 2nd.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  9. #278
    Registered User
    Join Date
    Apr 2011
    Location
    Castle Rock, CO
    Posts
    65
    Yikes , I just discovered this thread today after buying my 09 wrx hatch , 08/08 build date 504XXX vin . Damn you impluse buys. Im at 37k but bought the 100k "gold" warranty. Im taking it in to get lojack installed on Thursday. I will have to grill my Sales rep.

  10. #279
    The Fruit mangostick's Avatar
    Join Date
    Oct 2009
    Location
    VB VA .. the ghetto on the sea
    Posts
    4,735
    get the service history.. probably a good chance at that mileage you're already on the second engine.. or you didn't get a bad one. They were all failing with fairly low mileage on them. At 37K mi you should be fine. Good call on the warranty though.. having one's rear covered is priceless.
    OBP 2010 5dr *traded*
    SWP 2013 FRS
    My name is Shawn, I'm a Devout Practicalist and I'm addicted to flat4's
    This page has had 1,666 visits
    SUCH IS MANGO!

  11. #280
    Registered User Chader's Avatar
    Join Date
    Jan 2010
    Location
    Billings, MT
    Posts
    210
    Per NASIOC, (IIRC) there were at least a couple that popped above 30K mi.

    Definitely worth checking the history.
    2011 WRX 5-Door Premium
    Options - SPT Short Throw Shifter, SPT Exhaust
    Mods - Perrin 25mm FSB, Kartboy Front Endlinks, Cobb Shift Knob, Rally Armor Flaps, Seat bolster mod

  12. #281
    Registered User
    Join Date
    Apr 2011
    Posts
    1

    Mine blew at 49,998

    I bought my rex last aug. It has 49,998 and is now sitting at my local subi shop here in colorado spring co. I've been told they will let me know if SOA will pay for new engine or not. Not sure of man. date but my last six of my vin is 500395 so I know im in that range. Hope they take care of me. I'll update with subi's reply later today.... I hope.

  13. #282
    zax
    zax is offline
    \_(ツ)_/ zax's Avatar
    Join Date
    Nov 2008
    Location
    Neverland Ranch, Maryland
    Posts
    13,338
    I Support ClubWRX I Support ClubWRX
    Quote Originally Posted by Melm78 View Post
    It has 49,998
    Like clockwork
    2015 CWP WRX STi ... But how did I get roped back into an EJ motor?!
    Zax's utterly unimaginably stock 2015 STi build thread
    Zax's Shaggin' Wagon Build Thread Now tuned for 99% pure Unicorn Jizz!

    Zach | Moderator -- Mid-Atlantic States, Tech & Modifying & General Repairs
    Rollin' with the Bugeye Mafia #302 | N.E.R.D. Subject Zero
    Facebook me here

    Your Mid-A local board: http://www.clubwrx.net/forums/mid-atlantic-states/

  14. #283
    Registered User shadowpr's Avatar
    Join Date
    Jan 2011
    Location
    TX, NY
    Posts
    1,582
    that's scary for me. I just passed 36k, so I'm assuming i'm safe.

    Guess only time will tell. In the meantime, stage 2 here I come.

  15. #284
    Registered User Heide264's Avatar
    Join Date
    May 2010
    Location
    Pittsburgh, PA
    Posts
    4,222
    I Support ClubWRX
    I hate 'looming' issues like this. I am just planning on doing a minor engine build or picking up a rallispec block if mine goes - finances pending. I'd rather not fix it and risk it happening again - without at least improving my odds.
    Quote Originally Posted by Trainrex
    He was throwing balloons filled with sulfuric acid and shrapnel at the swat team. They finally had to take him down with rubber bullets.
    2011 STi Build Log
    -Part 1 - Reading, Data Logging, and Analyzing Data
    -Part 2 - Turbocharger 101 & Basic Boost Control
    -Part 3 - EcuFlash, Experimental Defintions, and a Drive By Wire Intro

  16. #285
    Registered User dolson1120's Avatar
    Join Date
    Oct 2010
    Location
    MN
    Posts
    129
    26,000 still driving strong!!!! It still is scary because I want to start a few mods now and don't want to crash and burn.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •