09 WRX Engine Failures - Page 18
Page 18 of 24 FirstFirst ... 89101112131415161718192021222324 LastLast
Results 256 to 270 of 349

This is a discussion on 09 WRX Engine Failures within the Everyday Impreza Talk forums, part of the Community - Meet other Enthusiasts category; Originally Posted by elwray No kidding... mine went at 8k. I was happy; got it over with. I wish I ...

  1. #256
    Registered User economatic's Avatar
    Join Date
    May 2009
    Location
    Portland, OR
    Posts
    840
    Quote Originally Posted by elwray View Post
    No kidding... mine went at 8k. I was happy; got it over with.
    I wish I could get it over with. I only have 6,600 miles on mine so if it goes at 48,000 that would put me at about 6 years past the powertrain warranty. ...wait a minute, this isn't funny...

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #257
    Registered User clutch43343's Avatar
    Join Date
    Sep 2010
    Location
    Pittsburgh, PA
    Posts
    8
    Unfortunately, mine just went last night...about 6:30 on a Saturday night...started as just a bit of a knock on my way home and turned into needing to flatbed it about 20 miles to get it to my house. After researching, it seems to be the spun rod bearing. Mine lasted 18,725 miles, but I've actually only owned it for less than a 4 weeks . I guess it's going up to the dealer tomorrow to get fixed under warranty...
    09 WRX Sedan
    Stink eye Mob #44

  4. #258
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,318
    I Support ClubWRX
    sorry to hear that I'd read through (very long unfortunately) the failure thread on nasioc as there is some good info/advice on how to deal with SOA (and the dealer)
    "Simplify and add lightness." - Colin Chapman

  5. #259
    Registered User clutch43343's Avatar
    Join Date
    Sep 2010
    Location
    Pittsburgh, PA
    Posts
    8
    Just dropped Rexx off at the dealership...The shop guy told me they were probably gonna end up putting a long block in it, but they would tear into it tonight or early tomorrow and he'd call me and let me know what's going on. As soon as I told him it wouldn't start and that I thought I spun a rod bearing, he asked if it was an '09, and when I said it was he told me that was most likely it. He actually started it up in the parking space, and within the first second he told me the bottom end was gone and shut it off again. I'll know the prognosis tomorrow sometime...
    09 WRX Sedan
    Stink eye Mob #44

  6. #260
    Registered User
    Join Date
    Dec 2010
    Posts
    3
    Well seems like I got the same issue with mine. Still waiting on word back from the dealer. But the noise is the same as the vids. Just got 21k miles. I bought it used about 3 weeks ago. Guess the girl that had it before me babied it a lil too much. It bit the bullet on me.

  7. #261
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,318
    I Support ClubWRX
    ^ sorry to hear that- make sure you read this thread through and another on nasioc to insure your getting the full customer service due
    "Simplify and add lightness." - Colin Chapman

  8. #262
    Registered User
    Join Date
    Dec 2010
    Posts
    3
    I already purchaed the gold warranty when I bought the car. What else would I be entitled too. My car is bone stock.

  9. #263
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,318
    I Support ClubWRX
    ahh- that was the biggie, mine was out long enough (there was a turbo shortage at the time) they gave me $ for a car payment

    good loaner car at the minimum, maybe they can reimburse some of the gold warranty cost????? accessories????
    "Simplify and add lightness." - Colin Chapman

  10. #264
    Registered User
    Join Date
    Dec 2010
    Posts
    3
    Yeah mines been gone a week already. They didn't wanna give me a loaner car til they could find out what it was and how long it would take to fix. So ill go in there today and pick one up. I could use an exhaust maybe ill ask for that. Haha or my first months payment as I haven't even had to male one yet and its already back to get fixed. Alrighty well thanks for the help.

  11. #265
    Moderating on the run! Big Sky WRX's Avatar
    Join Date
    Jul 2001
    Location
    Plains of Eastern Montana
    Posts
    12,318
    I Support ClubWRX
    make sure you call SOA (if you haven't already) and get an incident number- they're usually the ones in the position to make things right- including getting a loaner pronto

    be sure to tell the dealership that you've done so as that should smooth things out considerably
    "Simplify and add lightness." - Colin Chapman

  12. #266
    Registered User 2w0r0x9's Avatar
    Join Date
    May 2009
    Location
    LBI, NJ
    Posts
    431
    i hate seeing this thread pop up..

    my 09 w. 08/08 build is at 35,000 and still going strong.......for now

    *knock on wood*

    good luck getting yours fixed..let us know how it went

  13. #267
    Registered User kalidas's Avatar
    Join Date
    Jan 2009
    Location
    Tucson, AZ
    Posts
    258
    Wow, 48k that's scary. I am getting up there with mine, almost 45k now. The thing that really frightens me is the powertrain warranty ends at 60k. I was thinking I was mostly in the clear, but a failure at 48 is way too close to 60 for comfort.

  14. #268
    Registered User shadowpr's Avatar
    Join Date
    Jan 2011
    Location
    TX, NY
    Posts
    1,579
    Mine as a Sept build date. Have about 24k on it now. So far so good.

  15. #269
    Registered User
    Join Date
    Feb 2011
    Location
    Cinainnati Ohio
    Posts
    2
    Just bought a beautiful 09 WRX, hatch. Had it a week and heard some bad knocking. Turned out the previous owner had the infamous rod bearing issue. The dealership fixed the problem but apparently neglected to secure the fly wheel. The dealer replaced the fly wheel and the clutch assembly. They said they changed the oil, test drove it and changed the oil again and gave the ok. Got it back and it drives great, but little worried about future problems. Is there anything to worry about with the crank or tranny with the fly wheel not being torqued properly??

  16. #270
    Registered User
    Join Date
    Mar 2011
    Location
    Marion, Iowa
    Posts
    3
    I bought one with 15k. No issues. I have rev hang-up as well but I believe it's due to my timing during shifts. If I concentrate it's fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •