Turbo Coolant Reservoir Mod...
+ Reply to Thread
Page 1 of 3 123 LastLast
Results 1 to 15 of 34

This is a discussion on Turbo Coolant Reservoir Mod... within the Engine Performance forums, part of the Tutorials & DIY category; this is from scoobymods.com and im gonna post it here in case some of you don't know about that site ...

  1. #1
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294

    Turbo Coolant Reservoir Mod...

    this is from scoobymods.com and im gonna post it here in case some of you don't know about that site or check it very often.

    Originally posted by MisterX over on WRXFanatics.com in this thread

    I learned about this problem on a post on NASIOC where I've seen pics of coolant systems clogged pretty badly with paint chips. This mod is a bit obscure but that doesn't mean it's not important. The facts of the matter are, Subaru painted the lid of coolant reservoir for the turbo on earlier models. On later models, the lid remains unpainted. The problem is, the paint on the underside of the lid of the coolant reservoir blisters, peels, and clogs your coolant system. Later models are unpainted. I guess Subaru decided there was a problem.

    If your turbo coolant reservoir is painted black, you're going to have a problem. Here is a pic of me removing the coolant hoses from the top of the turbo coolant reservoir. Notice, it's painted black. As I said before, later models are unpainted.

    Ensure engine is cooled down.
    Remove Radiator Cap
    Remove 3 coolant hoses and make sure to hold them upright so they don't leak alot of coolant
    Remove the six 10mm bolts
    Use paint thinner or remover to remove the paint on the underside of the lid. Or use a dremel on the lowest setting and grind it off (like i did)
    Wash off with water
    Reinstall everything
    hope this helps people out who are anal about thier REX, like i am, plus, it only takes about 10-20 minutes to do.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User Prince Ali's Avatar
    Join Date
    May 2002
    Location
    Southern California
    Posts
    442

    Re: Turbo Coolant Reservoir Mod...

    Originally posted by pdrpowerofWRX
    this is from scoobymods.com and im gonna post it here in case some of you don't know about that site or check it very often.

    Originally posted by MisterX over on WRXFanatics.com in this thread

    I learned about this problem on a post on NASIOC where I've seen pics of coolant systems clogged pretty badly with paint chips. This mod is a bit obscure but that doesn't mean it's not important. The facts of the matter are, Subaru painted the lid of coolant reservoir for the turbo on earlier models. On later models, the lid remains unpainted. The problem is, the paint on the underside of the lid of the coolant reservoir blisters, peels, and clogs your coolant system. Later models are unpainted. I guess Subaru decided there was a problem.

    If your turbo coolant reservoir is painted black, you're going to have a problem. Here is a pic of me removing the coolant hoses from the top of the turbo coolant reservoir. Notice, it's painted black. As I said before, later models are unpainted.

    Ensure engine is cooled down.
    Remove Radiator Cap
    Remove 3 coolant hoses and make sure to hold them upright so they don't leak alot of coolant
    Remove the six 10mm bolts
    Use paint thinner or remover to remove the paint on the underside of the lid. Or use a dremel on the lowest setting and grind it off (like i did)
    Wash off with water
    Reinstall everything
    hope this helps people out who are anal about thier REX, like i am, plus, it only takes about 10-20 minutes to do.
    I can't believe how bad the paint was blistering. I removed the paint with lacquer thinner and removed the paint chips from the reservoir with a turkey baster.
    Thanks,
    Ali

  4. #3
    Moderating U! KurleeDaddeeWRX's Avatar
    Join Date
    Mar 2002
    Location
    San Jose, CA
    Posts
    6,317
    I Support ClubWRX
    I had the same problem:

    Radiator Filler Surface Rust

  5. #4

  6. #5
    Moderating U! KurleeDaddeeWRX's Avatar
    Join Date
    Mar 2002
    Location
    San Jose, CA
    Posts
    6,317
    I Support ClubWRX
    Originally posted by Timdog1650
    There is a TSB for this problem, subaru will replace any of the painted covers free of charge on 02/03's
    Good info. I didn't know this. I would have gotten mine replaced when I had my car. There was all kinds of black paint chips floating around in the resevoir.

  7. #6
    Registered User pityr's Avatar
    Join Date
    Oct 2002
    Location
    Beaverton OR
    Posts
    804
    I just looked at the TSBs yesterday and didn't see anything about that.

    did you see it on the NHTSA web site?
    No one will truely be free until nerd persecution ends.

  8. #7
    Registered User Timdog1650's Avatar
    Join Date
    Aug 2002
    Location
    Virginia Beach, VA
    Posts
    6,170
    This is what I was told by my mechanics at Precision Tuning, and also confirmed by NJWRB-Twrx (I think). I know you can make them replace it though for sure...

  9. #8
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    can someone help me find the TSB?

  10. #9
    Registered User
    Join Date
    Jul 2002
    Posts
    31
    My paint actually was all off of the underside of the coolant reservoir when I checked mine. My thermostat went out at 49,000 miles and I have a feeling it was due to the paint chips in the coolant. Luckily it was still covered under warranty.

  11. #10
    Banned dark_rex's Avatar
    Join Date
    Aug 2001
    Location
    The Hub
    Posts
    12,157
    any need to pinch the hoses or clamp them shut? will they leak a lot?

    tia.

    dR

  12. #11
    Registered User Timdog1650's Avatar
    Join Date
    Aug 2002
    Location
    Virginia Beach, VA
    Posts
    6,170
    Mike, all the hoses on my resevoir are just pushed on, no clamps. It never hurts, but normal operation the coolant system doesn't break more than 1 bar of pressure on average, which isn't really enough to blow something off. Look at the hoses into your BOV, they see 1 bar regularly and don't have clamps on them....

  13. #12
    Registered User zoinks's Avatar
    Join Date
    Dec 2003
    Location
    Portland, OR
    Posts
    1,525
    Not trying to hijack, but I just wanted to share what I found a few months ago and the remedy. An angle grinder with a wire brush gets if off in about a minute tops and just use a wire hand brush to get inside lid opening. So as you can see a lot of paint was gone so hopefully with a flush I'll be good
    Attached Thumbnails Attached Thumbnails 100_0943.jpg   100_0944 copy.jpg  

  14. #13
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    Quote Originally Posted by dark_rex
    can someone help me find the TSB?
    this is probably waaaaay old, but yes, coolant will leak out. you can clamp them off or just prop them so they face up and no coolant will come out.
    also, the above pix show alot of paint coming off... i did mine at 14k miles and i only had a little bit of paint, but it was starting to come off. glad i did mine before it ruined the thermo or looked like the above pix.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  15. #14
    Registered User EvilCerealBoX's Avatar
    Join Date
    Nov 2003
    Location
    ATX
    Posts
    2,427
    i recently finally got a change to look at mine... there was only a few chips left... i'm scared now... cause not too long ago the top of my radiator started leaking, like the whole top... will a full flush get it fixed or is it too far gone? the radiator seems to work fine since i haven't had any overheating problems... should i be worried anwyays?
    Me ni utsuru kono yo wa jigoku to iu

  16. #15
    Moderator Integra96's Avatar
    Join Date
    Apr 2002
    Location
    Utah
    Posts
    16,989
    I Support ClubWRX
    Just to confirm, this was only an '02/'03 issue, right?
    "Did you sleep well?"
    "No, I made a couple of mistakes."
    -- Steven Wright

+ Reply to Thread
Page 1 of 3 123 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •