Turbo Coolant Reservoir Mod... - Page 2
+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 34

This is a discussion on Turbo Coolant Reservoir Mod... within the Engine Performance forums, part of the Tutorials & DIY category; Originally Posted by Integra96 Just to confirm, this was only an '02/'03 issue, right? I think they fixed it mid ...

  1. #16
    Registered User zoinks's Avatar
    Join Date
    Dec 2003
    Location
    Portland, OR
    Posts
    1,525
    Quote Originally Posted by Integra96
    Just to confirm, this was only an '02/'03 issue, right?
    I think they fixed it mid '02 but it could've been mid '03...If your top is black then you need to do it...if it's silver then your ok.

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User NopWRX's Avatar
    Join Date
    Jan 2003
    Location
    TX
    Posts
    400
    I'm doing this mod right after class today. I tried doing it this morning but the damn hoses are hard to take off. Oh well, better to be safe than sorry.
    2002 WRX COBB Stage 2.5

    2003 Infiniti FX45

  4. #18
    Registered User
    Join Date
    Jun 2004
    Posts
    4,016
    did mine this weekend finally. takes 15 minutes.
    Vanitas vanitatum...et omnia vanitas

  5. #19
    Registered User zoinks's Avatar
    Join Date
    Dec 2003
    Location
    Portland, OR
    Posts
    1,525
    Quote Originally Posted by NopWRX
    I'm doing this mod right after class today. I tried doing it this morning but the damn hoses are hard to take off. Oh well, better to be safe than sorry.
    It helps if you twist the hoses a bit. I used a pair of channel locks with very light pressure as to not harm the hoses. They came right off.

  6. #20
    Registered User NopWRX's Avatar
    Join Date
    Jan 2003
    Location
    TX
    Posts
    400
    Cool, thanks for your help.



    P.S. Finished in about 30 minutes front and back cover with some paint remover.
    Last edited by NopWRX; 03-01-2005 at 02:08 PM.
    2002 WRX COBB Stage 2.5

    2003 Infiniti FX45

  7. #21
    Registered User
    Join Date
    Jun 2004
    Posts
    4,016
    yep. the hoses tend to stick. a pair of pliers and a quick squeeze & twist will break them loose then they pop right off!
    Vanitas vanitatum...et omnia vanitas

  8. #22
    Registered User Solid_Snake1234's Avatar
    Join Date
    Sep 2003
    Location
    Westport, CT
    Posts
    137
    i did this to but since it was in the cold it took me about 2 hrs because the paint thinner wasn't really that good. also i used a wire brush for to get more of the paint off. now i put everything back on but i have a problem when i start it i am hearing a whistling high pitch sound now. i need some help quick whats wrong? thx for the reply

  9. #23
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    here is the pic you asked for... hope it helps out some. good luck!
    Last edited by pdrpowerofWRX; 12-08-2005 at 05:05 PM.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  10. #24
    Registered User Solid_Snake1234's Avatar
    Join Date
    Sep 2003
    Location
    Westport, CT
    Posts
    137
    alright i started it up yesterday monring and there was no sound so i thought it was fine. i went to work and squeezed the hose to the radiator to feel it it was stiff which meant it had either air in it or as overheating. well i opened the coolant cap little by little to let out the air. when some coolant came out it was coming through the space of the bolt and the black metal plate. not sure if the car is overheating the guage inside isn't going to high but the hose that connects to the radiator is getting really hot and very stiff which usually means its overheating if i'm correct. it might be air in the system i'll try to burp it today but not sure if it will work. also the car is overheating why is this happening. do you think i should untightening everything and try to put it back on. i didn't tightening the bolts diagonally. should i have?
    Last edited by Solid_Snake1234; 03-14-2005 at 12:11 PM.

  11. #25
    Registered User
    Join Date
    Jun 2004
    Posts
    4,016
    yeah take everything apart and re-tourque down.

    do it liek a wheel.

    opposite corners hand tight first, then torque down.
    Vanitas vanitatum...et omnia vanitas

  12. #26
    Registered User pdrpowerofWRX's Avatar
    Join Date
    Aug 2002
    Location
    Springfield, OH.
    Posts
    1,294
    Quote Originally Posted by gusto
    yeah take everything apart and re-tourque down.

    do it liek a wheel.

    opposite corners hand tight first, then torque down.
    +1 and maybe even take it to the dealer and have a flush done.
    '05 CGM Subaru Impreza WRX Mods
    '02 WRB Subaru Impreza WRX (sold)
    '94 Subaru Legacy Wagon L (daily)
    '90 Toyota Supra Turbo

  13. #27
    Registered User Solid_Snake1234's Avatar
    Join Date
    Sep 2003
    Location
    Westport, CT
    Posts
    137
    when i'm burping the system do i have to keep adding coolant into where the radiator cap is. also when i was squeezing the hose connected to radiator and it would overflow onto the black pan none of the coolant was going through any of the screw holes so that's all set. also after i drive for a while the hose connected to the radiator was very stiff which usually means there is a lot of air in there or overheating. the gauge inside the car wasn't on the third line though. can someone tell me what's wrong?

  14. #28
    Registered User Solid_Snake1234's Avatar
    Join Date
    Sep 2003
    Location
    Westport, CT
    Posts
    137
    everything is all set now the thing was leaking so the place i had it replaced put a new one on and did a coolant change as well. man it was about $217 for everything. damn labor. i would have done it myself but i don't have any tools right now. and didn't have the time to do it.
    Last edited by Solid_Snake1234; 03-18-2005 at 03:37 PM.

  15. #29
    Registered User
    Join Date
    Feb 2006
    Location
    Siren, WI
    Posts
    231
    So how do you "flush" the turbo system? How can you be certain those little hoses aren't already clogged?

  16. #30
    Registered User WRXreX's Avatar
    Join Date
    Mar 2002
    Location
    NY
    Posts
    997
    I am going to do this this week. This is one of the must to do mod for 02 WRX...

+ Reply to Thread
Page 2 of 3 FirstFirst 123 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •