Samco I/C hose installation on WRX with PICS! - Page 2
Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 49

This is a discussion on Samco I/C hose installation on WRX with PICS! within the Engine Performance forums, part of the Tutorials & DIY category; what a whimp the BOV hose is a bast-ard, the clamp on the turbo side is upside down and will ...

  1. #16
    Registered User
    Join Date
    Aug 2002
    Location
    Cleveland, OH
    Posts
    8
    what a whimp

    the BOV hose is a bast-ard, the clamp on the turbo side is upside down and will cause MUCH cussing

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #17
    Registered User
    Join Date
    Feb 2003
    Location
    New York
    Posts
    20
    Where can I find info on that hose kit?

    How much did u pay for the whole thing?

  4. #18
    Banned jedimaster's Avatar
    Join Date
    Jun 2002
    Posts
    2,382
    Nice instructions, but you forgot to include what itmes you need to remove- you say remove the following, and then show the entire engine bay.

  5. #19
    Moderating U! KurleeDaddeeWRX's Avatar
    Join Date
    Mar 2002
    Location
    San Jose, CA
    Posts
    6,316
    I Support ClubWRX
    Thank you very much for the very detailed descriptions and pictures. Just what we need at this club. Very informative.

  6. #20
    Registered User CustomS10's Avatar
    Join Date
    Nov 2002
    Location
    Western Mass
    Posts
    7,959
    Originally posted by jedimaster
    Nice instructions, but you forgot to include what itmes you need to remove- you say remove the following, and then show the entire engine bay.
    in small red letters he has numbers on what needs to be removed. i'm guessing in what order also.
    -Ben-
    Spark it or Park it!

  7. #21
    Banned jedimaster's Avatar
    Join Date
    Jun 2002
    Posts
    2,382
    Hmmm, you're right- couldn't see it on my crappy comp at work.

  8. #22
    Moderator Penguinking's Avatar
    Join Date
    Nov 2001
    Location
    Houston, TX / Athens, GA -at the same time!
    Posts
    2,472
    I Support ClubWRX
    what's that black line on your intake manifold thats sitting just left of the throttle cables?
    Silver 911
    WRX's older brother

  9. #23
    Banned jedimaster's Avatar
    Join Date
    Jun 2002
    Posts
    2,382
    Look closer.
    Attached Thumbnails Attached Thumbnails eyetest.gif  

  10. #24
    Registered User
    Join Date
    Feb 2003
    Location
    New York
    Posts
    20
    Ive heard that Samco Hoses need to be "trimmed" on the inside....did you have to do this? And if so, where and what needed to be removed.

    Thanks

  11. #25
    Registered User WRXreX's Avatar
    Join Date
    Mar 2002
    Location
    NY
    Posts
    997
    To be honest with you, effects of pieces that need to be trimmed are nearly negligible. Some vendors make such a big deal out of it as if it is a big deal. Takes 5 min to trim them off..

  12. #26
    Registered User
    Join Date
    Feb 2003
    Location
    New York
    Posts
    20
    Originally posted by WRXreX
    To be honest with you, effects of pieces that need to be trimmed are nearly negligible. Some vendors make such a big deal out of it as if it is a big deal. Takes 5 min to trim them off..
    Can you elaborate on what needs to be trimmed and why?


    Thanks.

  13. #27
    Registered User
    Join Date
    Jan 2003
    Location
    Pittsburgh, PA
    Posts
    62

    new install

    I just installed the samco hoses...well 2 out of the three. the third hose from the BOV was a pain because of the clamp. Is there a way to get that clamp off without destroying everything around it or cutting the hose? I am more than frustruated and need help. Thanks in advance.

  14. #28
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    I'll be installing mine tomorrow, so I will post up if I run into any trouble.

    Q: Does the "flash" inside the Y hose need to be trimmed? Does anything else need to be trimmed?
    03 Cobra
    566whp/515wtq

    Pics
    & Dyno
    Pics

  15. #29
    Registered User BlkWRXWag's Avatar
    Join Date
    Jan 2003
    Location
    Trabuco Canyon, CA
    Posts
    2,236
    I got that clamp off by managing to get a pair of pliers on it and twisting it so the that top of the clamp is pointing upwards - then you can get a good grip on it with the pliers and squeeze.

    Aj - I just trimmed the flash with a utility knife, but be sure not to accidentally cut the main hose. If in doubt, I would just leave it.

  16. #30
    Registered User AjIsDope's Avatar
    Join Date
    Aug 2002
    Location
    SoCal
    Posts
    7,759
    Originally posted by BlkWRXWag
    I got that clamp off by managing to get a pair of pliers on it and twisting it so the that top of the clamp is pointing upwards - then you can get a good grip on it with the pliers and squeeze.

    Aj - I just trimmed the flash with a utility knife, but be sure not to accidentally cut the main hose. If in doubt, I would just leave it.
    To move that clamp, use a good pair of NEEDLE NOSE pliers. They can really get in there.

    I'm not too worried about cutting the main hose. I used to build models so I have a pretty steady hand. I'm just curious if there is anything else that needs to be trimmed, and if the only flash I need to cut off is at the middle intersection of the Y hose.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •