cruise control problem
+ Reply to Thread
Results 1 to 7 of 7

This is a discussion on cruise control problem within the Engine Performance forums, part of the Tutorials & DIY category; perrin o2 simulator is this good or not and how install usdm 04 sti cel and cruise control blink cruise ...

  1. #1
    Registered User
    Join Date
    Nov 2006
    Posts
    3

    cruise control problem

    perrin o2 simulator is this good or not and how install
    usdm 04 sti
    cel and cruise control blink
    cruise control not working after perrin downpipe
    max rpm. like fuel cut

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,245
    I Support ClubWRX
    It does sound like your 02 sensor may be screwed up. Also, with a new DP and no cats on an 04 STi, you may be getting fuel cut. Do you have a cat back exhaust on too?

    The perrin simulator works, but I can't say for sure it is the cause of your CEL and blinking cruise light. Do you have a way to "pull" the CEL so you read the code and post it here?
    Last edited by YBNormal07; 11-08-2006 at 05:20 AM.
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  4. #3
    Registered User
    Join Date
    Nov 2006
    Posts
    3
    Quote Originally Posted by YBNormal07 View Post
    It does sound like your 02 sensor may be screwed up. Also, with a new DP and no cats on an 04 STi, you may be getting fuel cut. Do you have a cat back exhaust on too?

    The perrin simulator works, but I can't say for sure it is the cause of your CEL and blinking cruise light. Do you have a way to "pull" the CEL so you read the code and post it here?
    i have a cat back too.
    how install o2 sensor

  5. #4
    Moderator YBNormal07's Avatar
    Join Date
    Jul 2003
    Location
    PA
    Posts
    6,245
    I Support ClubWRX
    Before you do this, you need to read the CEL to find out what is wrong.

    If it is fuel cut, you will need to port the wastegate, install a DP with a high flow catalytic converter, or put your stock catback back on. This will eliminate the boost creep and fuel cut.

    If it is the 02 sensor, just replacing it would be better than the Perrin 02 simulator.

    Do you have any engine management? Cobb AP? UTEC? Ecutek?

    With the DP and Catback, you really should have engine managment in order to properly control your air to fuel rations. The engine is very likely running extremely rich right now, and that could be source of your problems.

    So..first...find out what the CEL code is and post it up here.
    tEh PriUs=teH faSTah!@@!
    08 Audi S5 Black Diamond edition
    SOLD: 05 SWP Legacy GT Limited 5MT, 13.3ish@105 (stage 2) crappy stock clutch
    SOLD: 04 MPS/SW WRX Sti. 12.971 @ 103.97 (stock)
    278 AWHP/283 AWT, Catback exhaust
    306 AWHP/341 AWT, Stage 2
    (Scott) Moderator-STi, Drag Racing, Car Purchasing, and Tutorial Forums

  6. #5
    Registered User rr1911's Avatar
    Join Date
    Nov 2005
    Location
    Central Florida
    Posts
    0
    you can extend the wires on the o2 sensor and put the sensor behind the cat and this should solve ur problem
    Army Ranger For Life ! Thin Blue Line
    Military Militia # 1911/ Blobeye Syndicate # 1911/ Modifier's Anonymous # 1911/ Hawk-Eye Alliance # 1911
    All We'll Drive
    DIFFERENT STROKES
    EVEN MY DENTIST TOLD ME FLOSS 7 DAYS A WEEK
    POST WH0RE KING

  7. #6
    Registered User
    Join Date
    Aug 2004
    Location
    Costa Rica
    Posts
    27
    enkei where do you come from?

    my 04 sti have a same problem

  8. #7
    Registered User
    Join Date
    Nov 2006
    Posts
    3
    Quote Originally Posted by macholeee View Post
    enkei where do you come from?

    my 04 sti have a same problem
    i come from finland
    there is not us sti subaru parts because its complicated and prices is very expensiv.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.
If you do not want to register, fill this field only and the name will be used as user name for your post.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself. We strongly suggest that you stay away from using aol, yahoo, msn, and hotmail accounts. Sometimes the mail server blocks the emails from our server. As a result you will not receive any notifications including the confirmation email.

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •