Walbro 255 question?
Results 1 to 4 of 4

This is a discussion on Walbro 255 question? within the Engine Performance forums, part of the Tutorials & DIY category; Hey guys, I just ordered and received a walbro 255 fuel pump from Mach v Motorsports. Well when I opened ...

  1. #1
    Registered User ScoobyDew's Avatar
    Join Date
    Aug 2009
    Location
    NH
    Posts
    61

    Walbro 255 question?

    Hey guys, I just ordered and received a walbro 255 fuel pump from Mach v Motorsports. Well when I opened the box I found the pump covered in a light oil that smells similar to WD-40. I'm just wondering if this is normal packaging for the walbro pump? Maybe to prevent rust? Thanks

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User v6mx6ls36's Avatar
    Join Date
    Jan 2009
    Location
    El Paso Texas
    Posts
    367
    If I remember correctly mine was coated in a light grease aswell . Most likely to prevent rust or corrosion during storage or shipment

  4. #3
    Registered User metaldahlberg's Avatar
    Join Date
    Sep 2010
    Location
    NH
    Posts
    813
    Normal
    Contributing unsolicited, worthless opinions since 9/10...
    The project I spend all my money on.... <---- Click it

  5. #4
    Registered User ScoobyDew's Avatar
    Join Date
    Aug 2009
    Location
    NH
    Posts
    61
    Thanks guys! I'm just being paranoid again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •