Fuel Leak Problem With Injector Install!
Results 1 to 3 of 3

This is a discussion on Fuel Leak Problem With Injector Install! within the Engine Performance forums, part of the Tutorials & DIY category; So I was installing my injectors yesterday and i was confronted with a huge problem: the damn injectors won't stop ...

  1. #1
    Registered User
    Join Date
    Apr 2006
    Posts
    56

    Fuel Leak Problem With Injector Install!

    So I was installing my injectors yesterday and i was confronted with a huge problem: the damn injectors won't stop leaking! I've used the old O rings that were on my other injectors, and even newer ones that i believe were provided by DW. I lubed with up with gas, even tried vasoline, but to no avail, they still leak. And when I install them into the fuel line, I pull HARD, sometimes one clicks, yet still leaks, and for the most part the others don't click. I can't figure out this problem, can someone help?

  2. Remove Advertisements
    ClubWRX.net
    Advertisements
     

  3. #2
    Registered User
    Join Date
    Feb 2009
    Location
    miami, fl
    Posts
    36
    what kinda injectors are you using?

  4. #3
    Registered User mav3rik64's Avatar
    Join Date
    Dec 2009
    Location
    Arlington, TX
    Posts
    64
    Hey, sorry to dig up this thread, but since nothing had been resolved I don't see any harm in resurrecting it considering I encountered the same problem. I recently put in new injectors and about 2 weeks after my installation I needed to remove them due to some bad fuel, upon re-installation, the injector for cylinder 2 was leaky, so I re-seated it and that fixed the problem. The next day, I encountered the same problem but with injector number 3, so instinctively I removed it and checked the o'ring for cracks and stuff, then put it back in, unfortunately this time it didn't solve anything. Next i'm gonna switch around the injectors on that side and see if that fixed anything. Also, the grommet that buffers the fuel rail and the injector was loose and would move a little, whereas the other injectors were not. Any help on the matter would be appreciated as this is getting quite frustrating. Thanks
    A.K.A. The Stig

    "Some say, if he caught fire he would burn for 1000 days, and that the outline of his left nipple is exactly the same shape as the Nurburgring....all we know is, he's called The Stig" - Top Gear

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •